lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 18 Sep 2020 15:43:39 +0800
From:   "刘邵华BTD" <liush@...winnertech.com>
To:     "Christoph Hellwig" <hch@...radead.org>
Cc:     "paul.walmsley" <paul.walmsley@...ive.com>,
        "palmer" <palmer@...belt.com>, "aou" <aou@...s.berkeley.edu>,
        "akpm" <akpm@...ux-foundation.org>, "peterx" <peterx@...hat.com>,
        "walken" <walken@...gle.com>,
        "daniel.m.jordan" <daniel.m.jordan@...cle.com>,
        "vbabka" <vbabka@...e.cz>, "rppt" <rppt@...nel.org>,
        "linux-riscv" <linux-riscv@...ts.infradead.org>,
        "linux-kernel" <linux-kernel@...r.kernel.org>
Subject: 回复:[PATCH] riscv: fix pfn_to_virt err in do_page_fault().

Hi Christoph,
> On Thu, Sep 17, 2020 at 03:25:49PM +0800, liush wrote:
> > The argument to pfn_to_virt() should be pfn not the value of CSR_SATP.
> > 
> > Signed-off-by: liush <liush@...winnertech.com>
> > ---
> >  arch/riscv/mm/fault.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/arch/riscv/mm/fault.c b/arch/riscv/mm/fault.c
> > index 716d64e..9b4e088 100644
> > --- a/arch/riscv/mm/fault.c
> > +++ b/arch/riscv/mm/fault.c
> > @@ -212,7 +212,7 @@ asmlinkage void do_page_fault(struct pt_regs *regs)
> >     * of a task switch.
> >     */
> >    index = pgd_index(addr);
> > -  pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP)) + index;
> > +  pgd = (pgd_t *)pfn_to_virt(csr_read(CSR_SATP) & SATP_PPN) + index;

> This adds a crazy long line.  One nice way to clean this up would be to
> add a local pfn variable, as it would also make the code more readable.

Thanks, i'll modify it in next revision

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ