[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <4378d69a-2338-779f-ab4d-3c64fbf7dfd3@kapsi.fi>
Date: Mon, 21 Sep 2020 16:12:20 +0300
From: Mikko Perttunen <cyndis@...si.fi>
To: Qinglang Miao <miaoqinglang@...wei.com>,
Thierry Reding <thierry.reding@...il.com>
Cc: dri-devel@...ts.freedesktop.org, linux-tegra@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH -next] gpu: host1x: simplify the return expression of
host1x_cdma_init()
On 9/21/20 4:10 PM, Qinglang Miao wrote:
> Simplify the return expression.
>
> Signed-off-by: Qinglang Miao <miaoqinglang@...wei.com>
> ---
> drivers/gpu/host1x/cdma.c | 8 +-------
> 1 file changed, 1 insertion(+), 7 deletions(-)
>
> diff --git a/drivers/gpu/host1x/cdma.c b/drivers/gpu/host1x/cdma.c
> index e8d3fda91..08a0f9e10 100644
> --- a/drivers/gpu/host1x/cdma.c
> +++ b/drivers/gpu/host1x/cdma.c
> @@ -448,8 +448,6 @@ void host1x_cdma_update_sync_queue(struct host1x_cdma *cdma,
> */
> int host1x_cdma_init(struct host1x_cdma *cdma)
> {
> - int err;
> -
> mutex_init(&cdma->lock);
> init_completion(&cdma->complete);
>
> @@ -459,11 +457,7 @@ int host1x_cdma_init(struct host1x_cdma *cdma)
> cdma->running = false;
> cdma->torndown = false;
>
> - err = host1x_pushbuffer_init(&cdma->push_buffer);
> - if (err)
> - return err;
> -
> - return 0;
> + return host1x_pushbuffer_init(&cdma->push_buffer);
IMHO, this makes it less readable since now it kind of looks like
host1x_pushbuffer_init is returning some meaningful value, instead of
the code just handling error values in a sequence.
Mikko
> }
>
> /*
>
Powered by blists - more mailing lists