[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20200924094628.1085000-3-vincent.huang@tw.synaptics.com>
Date: Thu, 24 Sep 2020 17:46:27 +0800
From: Vincent Huang <vincent.huang@...synaptics.com>
To: linux-input@...r.kernel.org, linux-kernel@...r.kernel.org
Cc: Vincent Huang <vincent.huang@...synaptics.com>,
Dmitry Torokhov <dmitry.torokhov@...il.com>,
Jiri Kosina <jikos@...nel.org>,
Andrew Duggan <aduggan@...aptics.com>,
Hans de Goede <hdegoede@...hat.com>,
Benjamin Tissoires <btissoir@...hat.com>,
Lyude Paul <lyude@...hat.com>,
Chris Heiny <chris.heiny@...aptics.com>
Subject: [PATCH 2/3] HID: rmi - rename f30_data to gpio_data
f30_data in rmi_device_platform_data could be also referenced by RMI
function 3A, so rename it and the structure name to avoid confusion.
Signed-off-by: Vincent Huang <vincent.huang@...synaptics.com>
---
drivers/hid/hid-rmi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/hid/hid-rmi.c b/drivers/hid/hid-rmi.c
index 9ce22acdfaca..62315e31d520 100644
--- a/drivers/hid/hid-rmi.c
+++ b/drivers/hid/hid-rmi.c
@@ -722,7 +722,7 @@ static int rmi_probe(struct hid_device *hdev, const struct hid_device_id *id)
}
if (data->device_flags & RMI_DEVICE_HAS_PHYS_BUTTONS)
- rmi_hid_pdata.f30_data.disable = true;
+ rmi_hid_pdata.gpio_data.disable = true;
data->xport.dev = hdev->dev.parent;
data->xport.pdata = rmi_hid_pdata;
--
2.25.1
Powered by blists - more mailing lists