lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 2 Oct 2020 14:21:57 +0530
From:   Sameer Pujar <spujar@...dia.com>
To:     Dmitry Osipenko <digetx@...il.com>, <broonie@...nel.org>,
        <lgirdwood@...il.com>, <robh+dt@...nel.org>,
        <kuninori.morimoto.gx@...esas.com>,
        <pierre-louis.bossart@...ux.intel.com>, <perex@...ex.cz>,
        <tiwai@...e.com>, <thierry.reding@...il.com>,
        <jonathanh@...dia.com>
CC:     <alsa-devel@...a-project.org>, <devicetree@...r.kernel.org>,
        <linux-tegra@...r.kernel.org>, <linux-kernel@...r.kernel.org>,
        <sharadg@...dia.com>, <mkumard@...dia.com>,
        <viswanathl@...dia.com>, <rlokhande@...dia.com>,
        <dramesh@...dia.com>, <atalambedu@...dia.com>,
        <nwartikar@...dia.com>, <swarren@...dia.com>,
        <nicoleotsuka@...il.com>
Subject: Re: [PATCH v3 10/13] ASoC: tegra: Add audio graph based card driver


>>> +/* Setup PLL clock as per the given sample rate */
>>> +static int tegra_audio_graph_update_pll(struct snd_pcm_substream *substream,
>>> +                                    struct snd_pcm_hw_params *params)
>>> +{
>>> +    struct snd_soc_pcm_runtime *rtd = asoc_substream_to_rtd(substream);
>>> +    struct asoc_simple_priv *priv = snd_soc_card_get_drvdata(rtd->card);
>>> +    struct device *dev = rtd->card->dev;
>>> +    struct tegra_audio_graph_data *graph_data =
>>> +            (struct tegra_audio_graph_data *)priv->data;
>>> +    struct tegra_audio_chip_data *chip_data =
>>> +            (struct tegra_audio_chip_data *)of_device_get_match_data(dev);
>> void* doesn't need casting
>>
> There are several similar places in the code. Not a big deal, but this
> makes code less readable than it could be.

I will drop these in next revision.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ