[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20201015024237.25998-1-bernard@vivo.com>
Date: Wed, 14 Oct 2020 19:42:30 -0700
From: Bernard Zhao <bernard@...o.com>
To: Evan Quan <evan.quan@....com>,
Alex Deucher <alexander.deucher@....com>,
Christian König <christian.koenig@....com>,
David Airlie <airlied@...ux.ie>,
Daniel Vetter <daniel@...ll.ch>,
Kenneth Feng <kenneth.feng@....com>,
Qiu Wenbo <qiuwenbo@...tium.com.cn>,
YueHaibing <yuehaibing@...wei.com>,
Chen Wandun <chenwandun@...wei.com>,
yu kuai <yukuai3@...wei.com>, Bernard Zhao <bernard@...o.com>,
amd-gfx@...ts.freedesktop.org, dri-devel@...ts.freedesktop.org,
linux-kernel@...r.kernel.org
Cc: opensource.kernel@...o.com
Subject: [PATCH] drm/amd: remove unnecessary conversion from bool value to bool
In functions vegam_is_dpm_running & vegam_populate_avfs_parameters,
maybe there is no need to conver bool condition to bool variable
or bool return value.
This change is to make the code a bit more readable.
Signed-off-by: Bernard Zhao <bernard@...o.com>
---
drivers/gpu/drm/amd/powerplay/smumgr/vegam_smumgr.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/drivers/gpu/drm/amd/powerplay/smumgr/vegam_smumgr.c b/drivers/gpu/drm/amd/powerplay/smumgr/vegam_smumgr.c
index 0ecc18b55ffb..32ca472f58a6 100644
--- a/drivers/gpu/drm/amd/powerplay/smumgr/vegam_smumgr.c
+++ b/drivers/gpu/drm/amd/powerplay/smumgr/vegam_smumgr.c
@@ -296,8 +296,9 @@ static int vegam_process_firmware_header(struct pp_hwmgr *hwmgr)
static bool vegam_is_dpm_running(struct pp_hwmgr *hwmgr)
{
return (1 == PHM_READ_INDIRECT_FIELD(hwmgr->device,
- CGS_IND_REG__SMC, FEATURE_STATUS, VOLTAGE_CONTROLLER_ON))
- ? true : false;
+ CGS_IND_REG__SMC,
+ FEATURE_STATUS,
+ VOLTAGE_CONTROLLER_ON));
}
static uint32_t vegam_get_mac_definition(uint32_t value)
@@ -1661,7 +1662,7 @@ static int vegam_populate_avfs_parameters(struct pp_hwmgr *hwmgr)
(avfs_params.ucEnableGB_FUSE_TABLE_CKSON << AVFSGB0_Vdroop_Enable_SHIFT) |
(avfs_params.ucEnableGB_FUSE_TABLE_CKSOFF << AVFSGB1_Vdroop_Enable_SHIFT);
data->apply_avfs_cks_off_voltage =
- (avfs_params.ucEnableApplyAVFS_CKS_OFF_Voltage == 1) ? true : false;
+ (avfs_params.ucEnableApplyAVFS_CKS_OFF_Voltage == 1);
}
return result;
}
--
2.28.0
Powered by blists - more mailing lists