[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20201015130107.65195-1-linmiaohe@huawei.com>
Date: Thu, 15 Oct 2020 09:01:07 -0400
From: Miaohe Lin <linmiaohe@...wei.com>
To: <akpm@...ux-foundation.org>, <minchan@...nel.org>,
<ngupta@...are.org>, <sergey.senozhatsky.work@...il.com>
CC: <linux-mm@...ck.org>, <linux-kernel@...r.kernel.org>,
<linmiaohe@...wei.com>
Subject: [PATCH] zsmalloc: Rework the list_add code in insert_zspage()
Rework the list_add code to make it more readable and simplicity.
Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
---
mm/zsmalloc.c | 11 ++++-------
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/mm/zsmalloc.c b/mm/zsmalloc.c
index 918c7b019b3d..b03bee2e1b5f 100644
--- a/mm/zsmalloc.c
+++ b/mm/zsmalloc.c
@@ -730,13 +730,10 @@ static void insert_zspage(struct size_class *class,
* We want to see more ZS_FULL pages and less almost empty/full.
* Put pages with higher ->inuse first.
*/
- if (head) {
- if (get_zspage_inuse(zspage) < get_zspage_inuse(head)) {
- list_add(&zspage->list, &head->list);
- return;
- }
- }
- list_add(&zspage->list, &class->fullness_list[fullness]);
+ if (head && get_zspage_inuse(zspage) < get_zspage_inuse(head))
+ list_add(&zspage->list, &head->list);
+ else
+ list_add(&zspage->list, &class->fullness_list[fullness]);
}
/*
--
2.19.1
Powered by blists - more mailing lists