[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20201019202647.GD3713473@iweiny-DESK2.sc.intel.com>
Date: Mon, 19 Oct 2020 13:26:47 -0700
From: Ira Weiny <ira.weiny@...el.com>
To: Thomas Gleixner <tglx@...utronix.de>
Cc: Peter Zijlstra <peterz@...radead.org>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
Andy Lutomirski <luto@...nel.org>, x86@...nel.org,
Dave Hansen <dave.hansen@...ux.intel.com>,
Dan Williams <dan.j.williams@...el.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Fenghua Yu <fenghua.yu@...el.com>, linux-doc@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-nvdimm@...ts.01.org,
linux-fsdevel@...r.kernel.org, linux-mm@...ck.org,
linux-kselftest@...r.kernel.org
Subject: Re: [PATCH RFC V3 6/9] x86/entry: Pass irqentry_state_t by reference
On Mon, Oct 19, 2020 at 11:32:50AM +0200, Thomas Gleixner wrote:
> On Sun, Oct 18 2020 at 22:37, Ira Weiny wrote:
> > On Fri, Oct 16, 2020 at 02:55:21PM +0200, Thomas Gleixner wrote:
> >> Subject: x86/entry: Move nmi entry/exit into common code
> >> From: Thomas Gleixner <tglx@...utronix.de>
> >> Date: Fri, 11 Sep 2020 10:09:56 +0200
> >>
> >> Add blurb here.
> >
> > How about:
> >
> > To prepare for saving PKRS values across NMI's we lift the
> > idtentry_[enter|exit]_nmi() to the common code. Rename them to
> > irqentry_nmi_[enter|exit]() to reflect the new generic nature and store the
> > state in the same irqentry_state_t structure as the other irqentry_*()
> > functions. Finally, differentiate the state being stored between the NMI and
> > IRQ path by adding 'lockdep' to irqentry_state_t.
>
> No. This has absolutely nothing to do with PKRS. It's a cleanup valuable
> by itself and that's how it should have been done right away.
>
> So the proper changelog is:
>
> Lockdep state handling on NMI enter and exit is nothing specific to
> X86. It's not any different on other architectures. Also the extra
> state type is not necessary, irqentry_state_t can carry the necessary
> information as well.
>
> Move it to common code and extend irqentry_state_t to carry lockdep
> state.
Ok sounds good, thanks.
>
> >> --- a/include/linux/entry-common.h
> >> +++ b/include/linux/entry-common.h
> >> @@ -343,6 +343,7 @@ void irqentry_exit_to_user_mode(struct p
> >> #ifndef irqentry_state
> >> typedef struct irqentry_state {
> >> bool exit_rcu;
> >> + bool lockdep;
> >> } irqentry_state_t;
> >
> > Building on what Peter said do you agree this should be made into a union?
> >
> > It may not be strictly necessary in this patch but I think it would reflect the
> > mutual exclusivity better and could be changed easy enough in the follow on
> > patch which adds the pkrs state.
>
> Why the heck should it be changed in a patch which adds something
> completely different?
Because the PKRS stuff is used in both NMI and IRQ state.
>
> Either it's mutually exclusive or not and if so it want's to be done in
> this patch and not in a change which extends the struct for other
> reasons.
Sorry, let me clarify. After this patch we have.
typedef union irqentry_state {
bool exit_rcu;
bool lockdep;
} irqentry_state_t;
Which reflects the mutual exclusion of the 2 variables.
But then when the pkrs stuff is added the union changes back to a structure and
looks like this.
typedef struct irqentry_state {
#ifdef CONFIG_ARCH_HAS_SUPERVISOR_PKEYS
u32 pkrs;
u32 thread_pkrs;
#endif
union {
bool exit_rcu;
bool lockdep;
};
} irqentry_state_t;
Because the pkrs information is in addition to exit_rcu OR lockdep.
So this is what I meant by 'could be changed easy enough in the follow on
patch'.
Is that clear?
Ira
Powered by blists - more mailing lists