[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <1604046722-15531-1-git-send-email-luojiaxing@huawei.com>
Date: Fri, 30 Oct 2020 16:31:57 +0800
From: Luo Jiaxing <luojiaxing@...wei.com>
To: <akpm@...ux-foundation.org>, <viro@...iv.linux.org.uk>,
<andriy.shevchenko@...ux.intel.com>
CC: <linux-kernel@...r.kernel.org>, <martin.petersen@...cle.com>,
<john.garry@...wei.com>, <himanshu.madhani@...ium.com>,
<felipe.balbi@...ux.intel.com>, <gregkh@...uxfoundation.org>,
<uma.shankar@...el.com>, <anshuman.gupta@...el.com>,
<animesh.manna@...el.com>, <linux-usb@...r.kernel.org>,
<linux-scsi@...r.kernel.org>, <linuxarm@...wei.com>
Subject: [PATCH v2 0/5] Introduce a new helper marco DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c
We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers also want a helper marco for
read-write file too.
So we try to add this macro to help decrease code duplication.
Luo Jiaxing (5):
seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE
drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
.../gpu/drm/i915/display/intel_display_debugfs.c | 55 +--------
drivers/scsi/hisi_sas/hisi_sas_main.c | 135 +++------------------
drivers/scsi/qla2xxx/qla_dfs.c | 19 +--
drivers/usb/dwc3/debugfs.c | 52 +-------
include/linux/seq_file.h | 15 +++
5 files changed, 41 insertions(+), 235 deletions(-)
--
2.7.4
Powered by blists - more mailing lists