lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 9 Nov 2020 13:24:24 +0100
From:   Peter Zijlstra <peterz@...radead.org>
To:     paulmck@...nel.org
Cc:     rcu@...r.kernel.org, linux-kernel@...r.kernel.org,
        kernel-team@...com, mingo@...nel.org, jiangshanlai@...il.com,
        akpm@...ux-foundation.org, mathieu.desnoyers@...icios.com,
        josh@...htriplett.org, tglx@...utronix.de, rostedt@...dmis.org,
        dhowells@...hat.com, edumazet@...gle.com, fweisbec@...il.com,
        oleg@...hat.com, joel@...lfernandes.org, Hui Su <sh_def@....com>
Subject: Re: [PATCH tip/core/rcu 4/4] docs/rcu: Update the call_rcu() API

On Thu, Nov 05, 2020 at 03:05:10PM -0800, paulmck@...nel.org wrote:
> From: Hui Su <sh_def@....com>
> 
> This commit updates the documented API of call_rcu() to use the
> rcu_callback_t typedef instead of the open-coded function definition.
> 
> Signed-off-by: Hui Su <sh_def@....com>
> Signed-off-by: Paul E. McKenney <paulmck@...nel.org>
> ---
>  Documentation/RCU/whatisRCU.rst | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/Documentation/RCU/whatisRCU.rst b/Documentation/RCU/whatisRCU.rst
> index fb3ff76..1a4723f 100644
> --- a/Documentation/RCU/whatisRCU.rst
> +++ b/Documentation/RCU/whatisRCU.rst
> @@ -497,8 +497,7 @@ long -- there might be other high-priority work to be done.
>  In such cases, one uses call_rcu() rather than synchronize_rcu().
>  The call_rcu() API is as follows::
>  
> -	void call_rcu(struct rcu_head * head,
> -		      void (*func)(struct rcu_head *head));
> +	void call_rcu(struct rcu_head *head, rcu_callback_t func);

Personally I much prefer the old form, because now I have to go look up
rcu_callback_t to figure out wtf kind of signature is actually required.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ