lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 12 Nov 2020 15:07:38 +0800
From:   Luo Jiaxing <luojiaxing@...wei.com>
To:     <akpm@...ux-foundation.org>, <viro@...iv.linux.org.uk>,
        <andriy.shevchenko@...ux.intel.com>
CC:     <linux-kernel@...r.kernel.org>, <martin.petersen@...cle.com>,
        <john.garry@...wei.com>, <himanshu.madhani@...ium.com>,
        <felipe.balbi@...ux.intel.com>, <gregkh@...uxfoundation.org>,
        <uma.shankar@...el.com>, <anshuman.gupta@...el.com>,
        <animesh.manna@...el.com>, <linux-usb@...r.kernel.org>,
        <linux-scsi@...r.kernel.org>, <linuxarm@...wei.com>
Subject: [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c

We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers also want a helper macro
for read-write file too.

So we add this macro to help decrease code duplication.

---
 v1->v2:
        1.Rename DEFINE_STORE_ATTRIBUTE() to DEFINE_SHOW_STORE_ATTRIBUTE().
	2.AI Viro points out that he doesn't like the definition of macros
	  like DEFINE_SHOW_ATTRIBUTE.
 v2->v3:
        1.Fixed some spelling mistakes in commit.
        2.Revision description are added for easy tracing.

 v3->v4:
	1.Add AI Viro's comment to v1->v2's revision description.
	2.Fixed a spelling mistakes of "marco" to "macro".
---

Luo Jiaxing (5):
  seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
  scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
  scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
  usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE
  drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

 .../gpu/drm/i915/display/intel_display_debugfs.c   |  55 +--------
 drivers/scsi/hisi_sas/hisi_sas_main.c              | 135 +++------------------
 drivers/scsi/qla2xxx/qla_dfs.c                     |  19 +--
 drivers/usb/dwc3/debugfs.c                         |  52 +-------
 include/linux/seq_file.h                           |  15 +++
 5 files changed, 41 insertions(+), 235 deletions(-)

-- 
2.7.4

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ