lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 18 Nov 2020 20:25:54 +0530
From:   Soham Biswas <sohambiswas41@...il.com>
To:     thierry.reding@...il.com
Cc:     Lee Jones <lee.jones@...aro.org>,
        Uwe Kleine-König 
        <u.kleine-koenig@...gutronix.de>, linux-pwm@...r.kernel.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH v3] pwm: core: Use octal permission

On Wed, 18 Nov 2020 at 20:21, Soham Biswas <sohambiswas41@...il.com> wrote:
>
> Permission bits are easier readable in octal than with using the
> symbolic names.
>
> Fixes the following warning generated by checkpatch:
>
> drivers/pwm/core.c:1341: WARNING: Symbolic permissions 'S_IRUGO' are
> not preferred. Consider using octal permissions '0444'.
>
> +debugfs_create_file("pwm", S_IFREG | S_IRUGO, NULL, NULL,
>                             &pwm_debugfs_fops);
>
> Signed-off-by: Soham Biswas <sohambiswas41@...il.com>
> ---
>  drivers/pwm/core.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/pwm/core.c b/drivers/pwm/core.c
> index 1f16f5365d3c..a8eff4b3ee36 100644
> --- a/drivers/pwm/core.c
> +++ b/drivers/pwm/core.c
> @@ -1338,7 +1338,7 @@ DEFINE_SEQ_ATTRIBUTE(pwm_debugfs);
>
>  static int __init pwm_debugfs_init(void)
>  {
> -       debugfs_create_file("pwm", S_IFREG | S_IRUGO, NULL, NULL,
> +       debugfs_create_file("pwm", S_IFREG | 0444, NULL, NULL,
>                             &pwm_debugfs_fops);
>
>         return 0;
> --
> 2.29.2
>

I passed the `-v3` flag this time to the git format patch and fixed
the long lines error. It changed the name of the patch file though xD

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ