lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 21 Nov 2020 00:39:10 +0200
From:   Vladimir Oltean <>
To:     Christian Eggers <>
Cc:     Richard Cochran <>,
        Andrew Lunn <>,
        Heiner Kallweit <>,
        Jakub Kicinski <>,
        Russell King <>,
        "David S . Miller" <>,,
Subject: Re: [PATCH net-next v3 0/3] net: ptp: introduce common defines for
 PTP message types

On Fri, Nov 20, 2020 at 09:41:03AM +0100, Christian Eggers wrote:
> This series introduces commen defines for PTP event messages. Driver
> internal defines are removed and some uses of magic numbers are replaced
> by the new defines.
> Changes v2 --> v3
> ------------------
> - extend commit description for ptp_ines (Jacob Keller)
> Changes v1 --> v2
> ------------------
> - use defines instead of an enum (Richard Cochran)
> - no changes necessary for dp63640
> - add cover message (Vladimir Oltean)

I understand that you don't want to spend a lifetime on this, but I see
that there are more drivers which you did not touch.

is_sync() in drivers/net/phy/dp83640.c can be made to
	return ptp_get_msgtype(hdr, type) == PTP_MSGTYPE_SYNC;

this can be removed from drivers/net/ethernet/mellanox/mlxsw/spectrum_ptp.h:
enum {

Either way, this can also be applied as-is, since there's nothing wrong
with it.

Powered by blists - more mailing lists