[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <mhng-ca3ea720-b6b1-4b6e-a58f-43fadd7f1c18@palmerdabbelt-glaptop1>
Date: Fri, 20 Nov 2020 17:29:23 -0800 (PST)
From: Palmer Dabbelt <palmer@...belt.com>
To: zong.li@...ive.com
CC: Paul Walmsley <paul.walmsley@...ive.com>, sboyd@...nel.org,
schwab@...ux-m68k.org, pragnesh.patel@...nfive.com,
aou@...s.berkeley.edu, mturquette@...libre.com,
yash.shah@...ive.com, linux-kernel@...r.kernel.org,
linux-clk@...r.kernel.org, linux-riscv@...ts.infradead.org,
zong.li@...ive.com, Pragnesh.patel@...ive.com
Subject: Re: [PATCH v4 2/4] clk: sifive: Use common name for prci configuration
On Wed, 11 Nov 2020 02:06:06 PST (-0800), zong.li@...ive.com wrote:
> Use generic name CLK_SIFIVE_PRCI instead of CLK_SIFIVE_FU540_PRCI. This
> patch is prepared for fu740 support.
>
> Signed-off-by: Zong Li <zong.li@...ive.com>
> Reviewed-by: Palmer Dabbelt <palmerdabbelt@...gle.com>
> Acked-by: Palmer Dabbelt <palmerdabbelt@...gle.com>
> Reviewed-by: Pragnesh Patel <Pragnesh.patel@...ive.com>
> ---
> arch/riscv/Kconfig.socs | 2 +-
> drivers/clk/sifive/Kconfig | 6 +++---
> drivers/clk/sifive/Makefile | 2 +-
> 3 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/arch/riscv/Kconfig.socs b/arch/riscv/Kconfig.socs
> index 8a55f6156661..3284d5c291be 100644
> --- a/arch/riscv/Kconfig.socs
> +++ b/arch/riscv/Kconfig.socs
> @@ -5,7 +5,7 @@ config SOC_SIFIVE
> select SERIAL_SIFIVE if TTY
> select SERIAL_SIFIVE_CONSOLE if TTY
> select CLK_SIFIVE
> - select CLK_SIFIVE_FU540_PRCI
> + select CLK_SIFIVE_PRCI
> select SIFIVE_PLIC
> help
> This enables support for SiFive SoC platform hardware.
> diff --git a/drivers/clk/sifive/Kconfig b/drivers/clk/sifive/Kconfig
> index f3b4eb9cb0f5..ab48cf7e0105 100644
> --- a/drivers/clk/sifive/Kconfig
> +++ b/drivers/clk/sifive/Kconfig
> @@ -8,12 +8,12 @@ menuconfig CLK_SIFIVE
>
> if CLK_SIFIVE
>
> -config CLK_SIFIVE_FU540_PRCI
> - bool "PRCI driver for SiFive FU540 SoCs"
> +config CLK_SIFIVE_PRCI
> + bool "PRCI driver for SiFive SoCs"
> select CLK_ANALOGBITS_WRPLL_CLN28HPC
> help
> Supports the Power Reset Clock interface (PRCI) IP block found in
> - FU540 SoCs. If this kernel is meant to run on a SiFive FU540 SoC,
> + FU540 SoCs. If this kernel is meant to run on a SiFive FU540 SoC,
This just removes the double-space. Presumably in should also remove the
"FU540", as this clock driver will now function for multiple SiFive SOCs?
> enable this driver.
>
> endif
> diff --git a/drivers/clk/sifive/Makefile b/drivers/clk/sifive/Makefile
> index 627effe2ece1..fe3e2cb4c4d8 100644
> --- a/drivers/clk/sifive/Makefile
> +++ b/drivers/clk/sifive/Makefile
> @@ -1,4 +1,4 @@
> # SPDX-License-Identifier: GPL-2.0-only
> obj-y += sifive-prci.o
>
> -obj-$(CONFIG_CLK_SIFIVE_FU540_PRCI) += fu540-prci.o
> +obj-$(CONFIG_CLK_SIFIVE_PRCI) += fu540-prci.o
Probably best to rename the source file as well.
Powered by blists - more mailing lists