[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CANXhq0r+TOu_=c+KpNYFu3xzFtfmORoyDR+8mRrXwRCgpGWe8A@mail.gmail.com>
Date: Mon, 23 Nov 2020 15:16:39 +0800
From: Zong Li <zong.li@...ive.com>
To: Palmer Dabbelt <palmer@...belt.com>
Cc: Paul Walmsley <paul.walmsley@...ive.com>,
Stephen Boyd <sboyd@...nel.org>,
Andreas Schwab <schwab@...ux-m68k.org>,
Pragnesh Patel <pragnesh.patel@...nfive.com>,
Albert Ou <aou@...s.berkeley.edu>,
Michael Turquette <mturquette@...libre.com>,
Yash Shah <yash.shah@...ive.com>,
"linux-kernel@...r.kernel.org List" <linux-kernel@...r.kernel.org>,
linux-clk@...r.kernel.org,
linux-riscv <linux-riscv@...ts.infradead.org>,
Pragnesh Patel <Pragnesh.patel@...ive.com>
Subject: Re: [PATCH v4 2/4] clk: sifive: Use common name for prci configuration
On Sat, Nov 21, 2020 at 9:29 AM Palmer Dabbelt <palmer@...belt.com> wrote:
>
> On Wed, 11 Nov 2020 02:06:06 PST (-0800), zong.li@...ive.com wrote:
> > Use generic name CLK_SIFIVE_PRCI instead of CLK_SIFIVE_FU540_PRCI. This
> > patch is prepared for fu740 support.
> >
> > Signed-off-by: Zong Li <zong.li@...ive.com>
> > Reviewed-by: Palmer Dabbelt <palmerdabbelt@...gle.com>
> > Acked-by: Palmer Dabbelt <palmerdabbelt@...gle.com>
> > Reviewed-by: Pragnesh Patel <Pragnesh.patel@...ive.com>
> > ---
> > arch/riscv/Kconfig.socs | 2 +-
> > drivers/clk/sifive/Kconfig | 6 +++---
> > drivers/clk/sifive/Makefile | 2 +-
> > 3 files changed, 5 insertions(+), 5 deletions(-)
> >
> > diff --git a/arch/riscv/Kconfig.socs b/arch/riscv/Kconfig.socs
> > index 8a55f6156661..3284d5c291be 100644
> > --- a/arch/riscv/Kconfig.socs
> > +++ b/arch/riscv/Kconfig.socs
> > @@ -5,7 +5,7 @@ config SOC_SIFIVE
> > select SERIAL_SIFIVE if TTY
> > select SERIAL_SIFIVE_CONSOLE if TTY
> > select CLK_SIFIVE
> > - select CLK_SIFIVE_FU540_PRCI
> > + select CLK_SIFIVE_PRCI
> > select SIFIVE_PLIC
> > help
> > This enables support for SiFive SoC platform hardware.
> > diff --git a/drivers/clk/sifive/Kconfig b/drivers/clk/sifive/Kconfig
> > index f3b4eb9cb0f5..ab48cf7e0105 100644
> > --- a/drivers/clk/sifive/Kconfig
> > +++ b/drivers/clk/sifive/Kconfig
> > @@ -8,12 +8,12 @@ menuconfig CLK_SIFIVE
> >
> > if CLK_SIFIVE
> >
> > -config CLK_SIFIVE_FU540_PRCI
> > - bool "PRCI driver for SiFive FU540 SoCs"
> > +config CLK_SIFIVE_PRCI
> > + bool "PRCI driver for SiFive SoCs"
> > select CLK_ANALOGBITS_WRPLL_CLN28HPC
> > help
> > Supports the Power Reset Clock interface (PRCI) IP block found in
> > - FU540 SoCs. If this kernel is meant to run on a SiFive FU540 SoC,
> > + FU540 SoCs. If this kernel is meant to run on a SiFive FU540 SoC,
>
> This just removes the double-space. Presumably in should also remove the
> "FU540", as this clock driver will now function for multiple SiFive SOCs?
>
I'd like to list the support SoCs here, so in the third patch, I list
the FU740 in the description as well. I would remove the SoC names if
it is better by using a generic term. What do you think about that?
> > enable this driver.
> >
> > endif
> > diff --git a/drivers/clk/sifive/Makefile b/drivers/clk/sifive/Makefile
> > index 627effe2ece1..fe3e2cb4c4d8 100644
> > --- a/drivers/clk/sifive/Makefile
> > +++ b/drivers/clk/sifive/Makefile
> > @@ -1,4 +1,4 @@
> > # SPDX-License-Identifier: GPL-2.0-only
> > obj-y += sifive-prci.o
> >
> > -obj-$(CONFIG_CLK_SIFIVE_FU540_PRCI) += fu540-prci.o
> > +obj-$(CONFIG_CLK_SIFIVE_PRCI) += fu540-prci.o
>
> Probably best to rename the source file as well.
I added fu740-prci.c in the third patch, these two files fu740-prci.c
and fu540-prci.c hold the soc-dependent code, and sifive-prci.c is the
core of this driver.
Powered by blists - more mailing lists