[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHp75VeX8vRKzsE-GCMiDNcVnpXuQ2L2nJALvDyhVL9dO_JA-g@mail.gmail.com>
Date: Tue, 24 Nov 2020 13:47:11 +0200
From: Andy Shevchenko <andy.shevchenko@...il.com>
To: Alexandru Ardelean <alexandru.ardelean@...log.com>
Cc: linux-spi <linux-spi@...r.kernel.org>,
devicetree <devicetree@...r.kernel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Mark Brown <broonie@...nel.org>,
Rob Herring <robh+dt@...nel.org>,
"Bogdan, Dragos" <dragos.bogdan@...log.com>
Subject: Re: [PATCH v2 1/3] spi: convert to BIT() all spi_device flags
On Tue, Nov 24, 2020 at 12:16 PM Alexandru Ardelean
<alexandru.ardelean@...log.com> wrote:
>
> This change converts all bit flags for the 'struct spi_device' mode to the
> BIT() macro. The change is mostly for readability. Since adding more bit
> fields, might as well convert it now.
...
#include <linux/bits.h>
And honestly I think the entire inclusion block with data type forward
declarations should be revisited here.
...
> +#define SPI_CPHA BIT(0) /* clock phase */
> +#define SPI_CPOL BIT(1) /* clock polarity */
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists