[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c091e596-acfb-2d26-1c27-4388c22988cf@csgroup.eu>
Date: Tue, 1 Dec 2020 17:49:21 +0100
From: Christophe Leroy <christophe.leroy@...roup.eu>
To: Daniel Axtens <dja@...ens.net>, linux-kernel@...r.kernel.org,
linux-mm@...ck.org, linuxppc-dev@...ts.ozlabs.org,
kasan-dev@...glegroups.com, christophe.leroy@....fr,
aneesh.kumar@...ux.ibm.com, bsingharora@...il.com
Subject: Re: [PATCH v9 1/6] kasan: allow an architecture to disable inline
instrumentation
Le 01/12/2020 à 17:16, Daniel Axtens a écrit :
> For annoying architectural reasons, it's very difficult to support inline
> instrumentation on powerpc64.
>
> Add a Kconfig flag to allow an arch to disable inline. (It's a bit
> annoying to be 'backwards', but I'm not aware of any way to have
> an arch force a symbol to be 'n', rather than 'y'.)
>
> Signed-off-by: Daniel Axtens <dja@...ens.net>
> ---
> lib/Kconfig.kasan | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/lib/Kconfig.kasan b/lib/Kconfig.kasan
> index 542a9c18398e..31a0b28f6c2b 100644
> --- a/lib/Kconfig.kasan
> +++ b/lib/Kconfig.kasan
> @@ -9,6 +9,9 @@ config HAVE_ARCH_KASAN_SW_TAGS
> config HAVE_ARCH_KASAN_VMALLOC
> bool
>
> +config HAVE_ARCH_NO_KASAN_INLINE
Maybe a better name could be: ARCH_DISABLE_KASAN_INLINE
> + def_bool n
> +
> config CC_HAS_KASAN_GENERIC
> def_bool $(cc-option, -fsanitize=kernel-address)
>
> @@ -108,6 +111,7 @@ config KASAN_OUTLINE
>
> config KASAN_INLINE
> bool "Inline instrumentation"
> + depends on !HAVE_ARCH_NO_KASAN_INLINE
> help
> Compiler directly inserts code checking shadow memory before
> memory accesses. This is faster than outline (in some workloads
>
Powered by blists - more mailing lists