[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c45d327f-b669-a0ec-bd77-0c95dfd8db2c@huawei.com>
Date: Mon, 7 Dec 2020 15:41:38 +0800
From: Chao Yu <yuchao0@...wei.com>
To: Daeho Jeong <daeho43@...il.com>
CC: <linux-kernel@...r.kernel.org>,
<linux-f2fs-devel@...ts.sourceforge.net>,
<kernel-team@...roid.com>, Jaegeuk Kim <jaegeuk@...nel.org>,
Daeho Jeong <daehojeong@...gle.com>
Subject: Re: [f2fs-dev] [PATCH v3] f2fs: fix race of pending_pages in
decompression
On 2020/12/7 15:28, Daeho Jeong wrote:
>> It looks like it will be better to move this into merge condition?
>>
>> if (bio && (!page_is_mergeable(sbi, bio,
>> *last_block_in_bio, blkaddr) ||
>> !f2fs_crypt_mergeable_bio(bio, inode, page->index, NULL) ||
>> f2fs_verify_mergeable_bio())) {
>>
>
> I tried this for the first time, but it requires unnecessary checks
> within the compression cluster.
We only need to check f2fs_verify_mergeable_bio for i == 0 case? something like:
static bool f2fs_verify_mergeable_bio(struct bio *bio, bool verify, bool first_page)
{
if (!first_page)
return false;
if (!verify)
return false;
ctx = bio->bi_private;
if (!(ctx->enabled_steps & (1 << STEP_VERITY)))
return true;
}
Thoughts?
> I wanted to just check one time in the beginning of the cluster.
> What do you think?
It's trivial, but I'm think about the readability... at least, one line comment
is needed to describe why we submit previous bio. :)
Thanks,
> .
>
Powered by blists - more mailing lists