lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 13 Dec 2020 13:48:58 +0530
From:   Dwaipayan Ray <dwaipayanray1@...il.com>
To:     Lukas Bulwahn <lukas.bulwahn@...il.com>
Cc:     linux-leds@...r.kernel.org,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        Dan Murphy <dmurphy@...com>, Pavel Machek <pavel@....cz>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        linux-kernel-mentees@...ts.linuxfoundation.org
Subject: Re: [PATCH] leds: Use DEVICE_ATTR_{RW, RO, WO} macros

On Sun, Dec 13, 2020 at 1:31 PM Lukas Bulwahn <lukas.bulwahn@...il.com> wrote:
>
> On Sat, Dec 12, 2020 at 8:56 PM Dwaipayan Ray <dwaipayanray1@...il.com> wrote:
> >
> > Instead of open coding DEVICE_ATTR() defines, use the
> > DEVICE_ATTR_RW(), DEVICE_ATTR_WO(), and DEVICE_ATTR_RO()
> > macros intead.
>
> typo: s/intead/instead/
>
> No need to use the word "instead" twice in one sentence, though, we got it :)
>
> >
> > This required a few functions to be renamed, but the functionality
> > itself is unchanged.
> >
> > Note that this is compile tested only.
> >
>
> This note does not go in the commit message. In the future, this will
> be simply not true anymore, but this below the "---" (see HERE! as
> marker).
>
> For testing, you can generate the objdump of the binary before and
> after and compare if that is as expected.
>
> Other than that, the change itself looks good to me, so:
>
> Reviewed-by: Lukas Bulwahn <lukas.bulwahn@...il.com>
>
> Thanks, Dwaipayan, for fixing this up.
>
> Will you also add a checkpatch rule to identify other DEVICE_ATTR(...)
> that can be adjusted to the refined macros, so that checkpatch informs
> other submitters as well?
>

I think a checkpatch rule for this already exists. But it cannot automatically
rename the function names. That might be the only drawback we got.
Probably clang-format could fix these automatically.

> > Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
> > Cc: Dan Murphy <dmurphy@...com>
> > Cc: Pavel Machek <pavel@....cz>
> > Cc: Lukas Bulwahn <lukas.bulwahn@...il.com>
> > Cc: linux-leds@...r.kernel.org
> > Cc: linux-kernel@...r.kernel.org
> > Cc: linux-kernel-mentees@...ts.linuxfoundation.org
>
> As far as I know, the maintainers will add the Cc lines---if they like
> those---with script support.
>

I thought I might ease the work of maintainers to add those lines :(
But nevertheless I will remove them.

> > Signed-off-by: Dwaipayan Ray <dwaipayanray1@...il.com>
> > ---
>
> HERE!
>

Thanks Lukas.
I will be sending in a v2 if the led maintainers have no problem with
this patch.

Thank you,
Dwaipayan.

Powered by blists - more mailing lists