lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 14 Dec 2020 09:39:01 -0800
From:   Florian Fainelli <f.fainelli@...il.com>
To:     matthias.bgg@...nel.org, mpm@...enic.com,
        herbert@...dor.apana.org.au, rjui@...adcom.com,
        sbranden@...adcom.com, f.fainelli@...il.com
Cc:     linux-kernel@...r.kernel.org, Julia.Lawall@...ia.fr,
        bcm-kernel-feedback-list@...adcom.com,
        linux-arm-kernel@...ts.infradead.org, nsaenzjulienne@...e.de,
        linux-crypto@...r.kernel.org, Matthias Brugger <mbrugger@...e.com>
Subject: Re: [PATCH 2/2] hwrng: iproc-rng200: Move enable/disable in separate
 function

On 12/14/20 8:04 AM, matthias.bgg@...nel.org wrote:
> From: Matthias Brugger <mbrugger@...e.com>
> 
> We are calling the same code for enable and disable the block in various
> parts of the driver. Put that code into a new function to reduce code
> duplication.
> 
> Signed-off-by: Matthias Brugger <mbrugger@...e.com>
> 
> ---
> 
>  drivers/char/hw_random/iproc-rng200.c | 37 ++++++++++++---------------
>  1 file changed, 17 insertions(+), 20 deletions(-)
> 
> diff --git a/drivers/char/hw_random/iproc-rng200.c b/drivers/char/hw_random/iproc-rng200.c
> index e106ce3c0146..3367b26085e8 100644
> --- a/drivers/char/hw_random/iproc-rng200.c
> +++ b/drivers/char/hw_random/iproc-rng200.c
> @@ -53,15 +53,26 @@ struct iproc_rng200_dev {
>  
>  #define to_rng_priv(rng)	container_of(rng, struct iproc_rng200_dev, rng)
>  
> -static void iproc_rng200_restart(void __iomem *rng_base)
> +static void iproc_rng200_enable(void __iomem *rng_base, bool enable)

I would prefer naming the function iproc_rng200_enable_set() to indicate
that it sets the enable to the parameter value, this is just personal
taste, you may discard it.

>  {
>  	uint32_t val;

Since you are refactoring this into a new function, do you mind changing
the variable to u32 to match the kernel code? With that fixed:

Acked-by: Florian Fainelli <f.fainelli@...il.com>

Thanks!
-- 
Florian

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ