lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 28 Dec 2020 09:16:50 -0800
From:   Sean Christopherson <>
To:     Borislav Petkov <>
Cc:     Andy Lutomirski <>,
        Masami Hiramatsu <>,
        X86 ML <>, LKML <>
Subject: Re: [PATCH v1 01/19] x86/insn: Rename insn_decode() to

On Wed, Dec 23, 2020, Borislav Petkov wrote:
> From: Borislav Petkov <>
> Rename insn_decode() to insn_decode_regs() to denote that it receives
> regs as param and free the name for a more generic version of the
> function.

Can we add a preposition in there, e.g. insn_decode_from_regs() or
insn_decode_with_regs()?  For me, "decode_regs" means "decode the register
operands of the instruction".

Powered by blists - more mailing lists