lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 29 Dec 2020 20:36:05 +0100
From:   Borislav Petkov <>
To:     Sean Christopherson <>
Cc:     Andy Lutomirski <>,
        Masami Hiramatsu <>,
        X86 ML <>, LKML <>
Subject: Re: [PATCH v1 01/19] x86/insn: Rename insn_decode() to

On Mon, Dec 28, 2020 at 09:16:50AM -0800, Sean Christopherson wrote:
> Can we add a preposition in there, e.g. insn_decode_from_regs() or
> insn_decode_with_regs()?  For me, "decode_regs" means "decode the register
> operands of the instruction".

"...from_regs" it is.


Powered by blists - more mailing lists