lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 5 Jan 2021 00:47:12 +0000
From:   Vincent Pelletier <plr.vincent@...il.com>
To:     Masahiro Yamada <masahiroy@...nel.org>,
        Michal Marek <michal.lkml@...kovi.net>
Cc:     Rob Herring <robh@...nel.org>, linux-kbuild@...r.kernel.org,
        linux-kernel@...r.kernel.org
Subject: Re: Is there a reason not to use -@ to compile devicetrees ?

Ping ?

On Mon, 21 Dec 2020 14:47:07 +0000, Vincent Pelletier <plr.vincent@...il.com> wrote:
> Distro: https://raspi.debian.net/ (sid)
> Hardware: Raspberry Pi Zero W
> Kernel version: 5.9.11 (linux-image-5.9.0-4-rpi)
> 
> To access a device connected to my pi, I need the spi0 bus, and would
> like to not be doing GPIO bit-banging when there are perfectly good
> spi modules capable of using the SPI alternative mode of these pins.
> 
> spi0 is declared in the vanilla devicetree for this device:
> arch/arm/boot/dts/bcm2835-rpi-zero-w.dts ends up including
> arch/arm/boot/dts/bcm283x.dtsi which contains:
>                 spi: spi@...04000 {
>                         compatible = "brcm,bcm2835-spi";
>                         reg = <0x7e204000 0x200>;
>                         interrupts = <2 22>;
>                         clocks = <&clocks BCM2835_CLOCK_VPU>;
>                         #address-cells = <1>;
>                         #size-cells = <0>;
>                         status = "disabled";
>                 };
> To my new-to-devicetree eye, this looks like this is intended to be
> overridden, at least with a
>   status = "okay";
> property (although a bit more is needed).
> As I believe is the correct way, I wrote a devicetree overlay doing
> this and a bit more in order to enable this bus and one of its device
> (the one matching the chip-select monitored by the board I connected).
> 
> To confirm that I had no typo in my symbol names I ran fdtoverlay with
> the packaged device tree binary, plus my overlay, but could not get it
> to work, until I took a closer look at the packaged device tree and
> realised it lacks a __symbols__ section.
> So I pulled the source, added "-@" to the cmd_dtc rule in
> scripts/Makefile.lib, built the dtb, tested fdtoverlay against it and
> voila, it worked. I could then reboot with this devicetree, load my
> overlay and use spi0 with no further change.
> 
> So now I wonder why this option is not enabled while there are these
> sections which seem to not be usable without an overlay ?
> And further, why it does not seem to be possible to enable with a
> kernel config option ?
> 
> I must be missing something obvious, but I'm still failing to see it.
-- 
Vincent Pelletier

Powered by blists - more mailing lists