lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu,  7 Jan 2021 23:19:39 -0500
From:   "Martin K. Petersen" <martin.petersen@...cle.com>
To:     Randy Dunlap <rdunlap@...radead.org>, linux-kernel@...r.kernel.org
Cc:     "Martin K . Petersen" <martin.petersen@...cle.com>,
        kernel test robot <lkp@...el.com>,
        linux-scsi@...r.kernel.org,
        "James E.J. Bottomley" <jejb@...ux.ibm.com>,
        Avri Altman <avri.altman@....com>,
        Alim Akhtar <alim.akhtar@...sung.com>
Subject: Re: [PATCH] scsi: ufs: ufshcd-pltfrm depends on HAS_IOMEM

On Tue, 5 Jan 2021 20:08:22 -0800, Randy Dunlap wrote:

> Building ufshcd-pltfrm.c on arch/s390/ has a linker error since
> S390 does not support IOMEM, so add a dependency on HAS_IOMEM.
> 
> s390-linux-ld: drivers/scsi/ufs/ufshcd-pltfrm.o: in function `ufshcd_pltfrm_init':
> ufshcd-pltfrm.c:(.text+0x38e): undefined reference to `devm_platform_ioremap_resource'
> 
> where that devm_ function is inside an #ifdef CONFIG_HAS_IOMEM/#endif block.

Applied to 5.11/scsi-fixes, thanks!

[1/1] scsi: ufs: ufshcd-pltfrm depends on HAS_IOMEM
      https://git.kernel.org/mkp/scsi/c/5e6ddadf7637

-- 
Martin K. Petersen	Oracle Linux Engineering

Powered by blists - more mailing lists