lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 14 Jan 2021 10:04:19 +0900
From:   Stafford Horne <shorne@...il.com>
To:     Gabriel Somlo <gsomlo@...il.com>
Cc:     mholenko@...micro.com, kgugala@...micro.com,
        linux-kernel@...r.kernel.org, pczarnecki@...ernships.antmicro.com,
        f.kermarrec@...il.com, gregkh@...uxfoundation.org
Subject: Re: [PATCH v6 0/5] drivers/soc/litex: support 32-bit subregisters,
 64-bit CPUs

I have queued this for 5.12.

On Tue, Jan 12, 2021 at 12:31:39PM -0500, Gabriel Somlo wrote:
> This series expands on commit 22447a99c97e ("drivers/soc/litex: add LiteX
> SoC Controller driver"), adding support for handling both 8- and 32-bit
> LiteX CSR (MMIO) subregisters, on both 32- and 64-bit CPUs.
> 
> Notes v6:
> 	- split out s/LITEX_REG_SIZE/LITEX_SUBREG_ALIGN/g change
> 	  into its own dedicated (cosmetic-only) patch (3/5).
> 	- fixed typos in "main patch" (now 4/5) changelog.
> 	- fixed typos in comments added via patch 5/5.
> 
> Notes v5:
> 	- added patch (4/4) taking 'litex_[set|get]_reg()' private
> 	- additional optimization of [_]litex_set_reg() in 3/4
> 
> Notes v4:
> 	- improved "eloquence" of some 3/3 commit blurb paragraphs
> 	- fixed instance of "disgusting" comment style :)
> 	- litex_[get|set]_reg() now using size_t for 'reg_size' argument
> 	- slightly tighter shift calculation in litex_set_reg()
> 
> Notes v3:
> 	- split into smaller, more self-explanatory patches
> 	- more detailed commit blurb for "main payload" (3/3) patch
> 	- eliminate compiler warning on 32-bit architectures
> 
> Notes v2:
> 	- fix typo (s/u32/u64/) in litex_read64().
> 
> Notes v1:
> 	- LITEX_SUBREG_SIZE now provided by Kconfig.
> 	- it's not LITEX_REG_SIZE, but rather LITEX_SUBREG_ALIGN!
> 	- move litex_[get|set]_reg() to include/linux/litex.h and mark
> 	  them as "static inline";
> 	- redo litex_[read|write][8|16|32|64]() using litex_[get|set]_reg()
> 	  (compiler should produce code as efficient as hardcoded shifts,
> 	  but also automatically matching LITEX_SUBREG_SIZE).
> 
> Gabriel Somlo (5):
>   drivers/soc/litex: move generic accessors to litex.h
>   drivers/soc/litex: separate MMIO from subregister offset calculation
>   drivers/soc/litex: rename LITEX_REG_SIZE to LITEX_SUBREG_ALIGN
>   drivers/soc/litex: support 32-bit subregisters, 64-bit CPUs
>   drivers/soc/litex: make 'litex_[set|get]_reg()' methods private
> 
>  drivers/soc/litex/Kconfig          |  14 ++-
>  drivers/soc/litex/litex_soc_ctrl.c |  76 +-------------
>  include/linux/litex.h              | 154 +++++++++++++++++++----------
>  3 files changed, 119 insertions(+), 125 deletions(-)
> 
> -- 
> 2.26.2
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ