[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CALOAHbC+-BqQtXx3Miqa_6VboNA=5gsgTWzwJvk_uH_A+4SFAw@mail.gmail.com>
Date: Thu, 28 Jan 2021 15:42:38 +0800
From: Yafang Shao <laoar.shao@...il.com>
To: Joe Perches <joe@...ches.com>
Cc: David Hildenbrand <david@...hat.com>,
Vlastimil Babka <vbabka@...e.cz>,
Christoph Lameter <cl@...ux.com>, penberg@...nel.org,
David Rientjes <rientjes@...gle.com>, iamjoonsoo.kim@....com,
Andrew Morton <akpm@...ux-foundation.org>,
Petr Mladek <pmladek@...e.com>,
Steven Rostedt <rostedt@...dmis.org>,
Sergey Senozhatsky <sergey.senozhatsky@...il.com>,
andriy.shevchenko@...ux.intel.com,
Rasmus Villemoes <linux@...musvillemoes.dk>,
Linux MM <linux-mm@...ck.org>,
LKML <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 3/3] printk: dump full information of page flags in pGp
On Thu, Jan 28, 2021 at 10:35 AM Joe Perches <joe@...ches.com> wrote:
>
> On Thu, 2021-01-28 at 10:19 +0800, Yafang Shao wrote:
> > Currently the pGp only shows the names of page flags, rather than
> > the full information including section, node, zone, last cpupid and
> > kasan tag. While it is not easy to parse these information manually
> > because there're so many flavors. Let's interpret them in pGp as well.
> []
> > diff --git a/lib/vsprintf.c b/lib/vsprintf.c
> []
> > @@ -1916,6 +1916,46 @@ char *format_flags(char *buf, char *end, unsigned long flags,
> > return buf;
> > }
> >
> > +struct page_flags_layout {
> > + int width;
> > + int shift;
> > + int mask;
> > + char *name;
> > +};
> > +
> > +struct page_flags_layout pfl[] = {
>
> static const struct page_flags_layout pfl[] = {
Sure.
>
> > + {SECTIONS_WIDTH, SECTIONS_PGSHIFT, SECTIONS_MASK, "Section "},
> > + {NODES_WIDTH, NODES_PGSHIFT, NODES_MASK, "Node "},
> > + {ZONES_WIDTH, ZONES_PGSHIFT, ZONES_MASK, "Zone "},
> > + {LAST_CPUPID_WIDTH, LAST_CPUPID_PGSHIFT, LAST_CPUPID_MASK, "Lastcpupid "},
> > + {KASAN_TAG_WIDTH, KASAN_TAG_PGSHIFT, KASAN_TAG_MASK, "Kasantag "},
> > +};
> > +
> > +static
> > +char *format_layout(char *buf, char *end, unsigned long flags)
>
> poor name. perhaps format_page_flags
>
Thanks for the suggestion.
> > +{
> > + int i;
> > +
> > + for (i = 0; i < sizeof(pfl) / sizeof(struct page_flags_layout) && buf < end; i++) {
>
> for (i = 0; i < ARRAY_SIZE(pfl) && buf < end; i++) {
>
Sure.
>
> > @@ -1929,7 +1969,7 @@ char *flags_string(char *buf, char *end, void *flags_ptr,
> > switch (fmt[1]) {
> > case 'p':
> > flags = *(unsigned long *)flags_ptr;
> > - /* Remove zone id */
> > + buf = format_layout(buf, end, flags & ~((1UL << NR_PAGEFLAGS) - 1));
> > flags &= (1UL << NR_PAGEFLAGS) - 1;
>
> Perhaps store the bitshift into a temp and use the temp twice
>
> foo = BIT(NR_PAGEFLAGS) - 1;
>
> buf = format_layout(buf, end, flags & ~foo);
> flags &= foo;
>
>
Thanks for the suggestion. I will change them all.
--
Thanks
Yafang
Powered by blists - more mailing lists