[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20210130103823.28914-2-matwey@sai.msu.ru>
Date: Sat, 30 Jan 2021 13:38:23 +0300
From: "Matwey V. Kornilov" <matwey@....msu.ru>
To: Jean Delvare <jdelvare@...e.com>,
Guenter Roeck <linux@...ck-us.net>,
linux-hwmon@...r.kernel.org (open list:HARDWARE MONITORING),
linux-kernel@...r.kernel.org (open list)
Cc: matwey.kornilov@...il.com,
"Matwey V. Kornilov" <matwey@....msu.ru>,
linux-hwmon@...r.kernel.org (open list:HARDWARE MONITORING),
linux-kernel@...r.kernel.org (open list)
Subject: [PATCH 2/2] hwmon: lm75: Add another name for NXP LM75B to of_match list
NXP LM75B is compatible with original LM75A while it has improved
11-bit precision.
https://www.nxp.com/docs/en/data-sheet/LM75B.pdf
NXP LM75B support was added in
799fc6021430 ("hwmon: (lm75) Add support for the NXP LM75B")
OF compatible string "national,lm75b" for LM75B was created in
e97a45f1b460 ("hwmon: (lm75) Add OF device ID table")
Since the previous commit introduces "nxp,lm75a" compatible string
for LM75A, there is a reason to add another alias for LM75B.
Signed-off-by: Matwey V. Kornilov <matwey@....msu.ru>
---
drivers/hwmon/lm75.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/drivers/hwmon/lm75.c b/drivers/hwmon/lm75.c
index 37dc903ebf54..6cd951e062f0 100644
--- a/drivers/hwmon/lm75.c
+++ b/drivers/hwmon/lm75.c
@@ -703,6 +703,10 @@ static const struct of_device_id __maybe_unused lm75_of_match[] = {
.compatible = "nxp,lm75a",
.data = (void *)lm75b
},
+ {
+ .compatible = "nxp,lm75b",
+ .data = (void *)lm75b
+ },
{
.compatible = "maxim,max6625",
.data = (void *)max6625
--
2.26.2
Powered by blists - more mailing lists