[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <49529a7d-a8c0-c248-6868-8280c821455d@gmx.de>
Date: Wed, 3 Feb 2021 15:04:45 +0100
From: Helge Deller <deller@....de>
To: Tiezhu Yang <yangtiezhu@...ngson.cn>,
James.Bottomley@...senPartnership.com
Cc: linux-parisc@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] parisc: Replace test_ti_thread_flag() with
test_tsk_thread_flag()
On 2/3/21 6:27 AM, Tiezhu Yang wrote:
> Use test_tsk_thread_flag() directly instead of test_ti_thread_flag() to
> improve readability when the argument type is struct task_struct, it is
> similar with commit 5afc78551bf5 ("arm64: Use test_tsk_thread_flag() for
> checking TIF_SINGLESTEP").
>
> Signed-off-by: Tiezhu Yang <yangtiezhu@...ngson.cn>
Thanks!
Applied to the parisc git tree.
Helge
> ---
> arch/parisc/include/asm/compat.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/parisc/include/asm/compat.h b/arch/parisc/include/asm/compat.h
> index 8f33085..1a609d3 100644
> --- a/arch/parisc/include/asm/compat.h
> +++ b/arch/parisc/include/asm/compat.h
> @@ -179,7 +179,7 @@ static __inline__ void __user *arch_compat_alloc_user_space(long len)
>
> static inline int __is_compat_task(struct task_struct *t)
> {
> - return test_ti_thread_flag(task_thread_info(t), TIF_32BIT);
> + return test_tsk_thread_flag(t, TIF_32BIT);
> }
>
> static inline int is_compat_task(void)
>
Powered by blists - more mailing lists