[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHp75VcwTg1e=apHuOzCNmpK9c6LuZ_BLDZvq9BpaTC8Rcgguw@mail.gmail.com>
Date: Fri, 5 Feb 2021 17:53:41 +0200
From: Andy Shevchenko <andy.shevchenko@...il.com>
To: David Laight <David.Laight@...lab.com>
Cc: Richard Fitzgerald <rf@...nsource.cirrus.com>,
Petr Mladek <pmladek@...e.com>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Steven Rostedt <rostedt@...dmis.org>,
Sergey Senozhatsky <sergey.senozhatsky@...il.com>,
Rasmus Villemoes <linux@...musvillemoes.dk>,
Shuah Khan <shuah@...nel.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
"open list:KERNEL SELFTEST FRAMEWORK"
<linux-kselftest@...r.kernel.org>,
"patches@...nsource.cirrus.com" <patches@...nsource.cirrus.com>
Subject: Re: [PATCH v4 2/4] lib: vsprintf: Fix handling of number field widths
in vsscanf
On Fri, Feb 5, 2021 at 5:23 PM David Laight <David.Laight@...lab.com> wrote:
> From: Andy Shevchenko
> > Sent: 05 February 2021 12:51
> > On Fri, Feb 5, 2021 at 1:35 PM Richard Fitzgerald
> > <rf@...nsource.cirrus.com> wrote:
> > > On 04/02/2021 16:35, Petr Mladek wrote:
> > > > On Wed 2021-02-03 21:45:55, Andy Shevchenko wrote:
> > > >> On Wed, Feb 03, 2021 at 04:50:07PM +0000, Richard Fitzgerald wrote:
> >
> > ...
> >
> > > >>> + for (; max_chars > 0; max_chars--) {
> > > >>
> > > >> Less fragile is to write
> > > >>
> > > >> while (max_chars--)
> > > >
> > > > Except that the original was more obvious at least for me.
> > > > I always prefer more readable code when the compiler might do
> > > > the optimization easily. But this is my personal taste.
> > > > I am fine with both variants.
> >
> > I *slightly* prefer while-loop *in this case* due to less characters
> > to parse to understand the logic.
>
> The two loops are also have different values for 'max_chars'
> inside the loop body.
off-by-one to be precise.
> If 'max_chars' is known to be non-zero the do ... while (--max_chars);
> loop will probable generate better code.
What?! while (--x) and while(x--) are equivalent.
> But there is no accounting for just how odd some decisions gcc
> makes are.
Why should we care about the compiler bugs here?
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists