lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 7 Feb 2021 16:56:01 +0100
From:   Christoph Hellwig <hch@....de>
To:     Dongli Zhang <dongli.zhang@...cle.com>
Cc:     dri-devel@...ts.freedesktop.org, intel-gfx@...ts.freedesktop.org,
        iommu@...ts.linux-foundation.org, linux-mips@...r.kernel.org,
        linux-mmc@...r.kernel.org, linux-pci@...r.kernel.org,
        linuxppc-dev@...ts.ozlabs.org, nouveau@...ts.freedesktop.org,
        x86@...nel.org, xen-devel@...ts.xenproject.org,
        linux-kernel@...r.kernel.org, adrian.hunter@...el.com,
        akpm@...ux-foundation.org, benh@...nel.crashing.org,
        bskeggs@...hat.com, bhelgaas@...gle.com, bp@...en8.de,
        boris.ostrovsky@...cle.com, hch@....de, chris@...is-wilson.co.uk,
        daniel@...ll.ch, airlied@...ux.ie, hpa@...or.com, mingo@...nel.org,
        mingo@...hat.com, jani.nikula@...ux.intel.com,
        joonas.lahtinen@...ux.intel.com, jgross@...e.com,
        konrad.wilk@...cle.com, m.szyprowski@...sung.com,
        matthew.auld@...el.com, mpe@...erman.id.au, rppt@...nel.org,
        paulus@...ba.org, peterz@...radead.org, robin.murphy@....com,
        rodrigo.vivi@...el.com, sstabellini@...nel.org,
        bauerman@...ux.ibm.com, tsbogend@...ha.franken.de,
        tglx@...utronix.de, ulf.hansson@...aro.org, joe.jin@...cle.com,
        thomas.lendacky@....com
Subject: Re: [PATCH RFC v1 5/6] xen-swiotlb: convert variables to arrays

On Thu, Feb 04, 2021 at 09:40:23AM +0100, Christoph Hellwig wrote:
> So one thing that has been on my mind for a while:  I'd really like
> to kill the separate dma ops in Xen swiotlb.  If we compare xen-swiotlb
> to swiotlb the main difference seems to be:
> 
>  - additional reasons to bounce I/O vs the plain DMA capable
>  - the possibility to do a hypercall on arm/arm64
>  - an extra translation layer before doing the phys_to_dma and vice
>    versa
>  - an special memory allocator
> 
> I wonder if inbetween a few jump labels or other no overhead enablement
> options and possibly better use of the dma_range_map we could kill
> off most of swiotlb-xen instead of maintaining all this code duplication?

So I looked at this a bit more.

For x86 with XENFEAT_auto_translated_physmap (how common is that?)
pfn_to_gfn is a nop, so plain phys_to_dma/dma_to_phys do work as-is.

xen_arch_need_swiotlb always returns true for x86, and
range_straddles_page_boundary should never be true for the
XENFEAT_auto_translated_physmap case.

So as far as I can tell the mapping fast path for the
XENFEAT_auto_translated_physmap can be trivially reused from swiotlb.

That leaves us with the next more complicated case, x86 or fully cache
coherent arm{,64} without XENFEAT_auto_translated_physmap.  In that case
we need to patch in a phys_to_dma/dma_to_phys that performs the MFN
lookup, which could be done using alternatives or jump labels.
I think if that is done right we should also be able to let that cover
the foreign pages in is_xen_swiotlb_buffer/is_swiotlb_buffer, but
in that worst case that would need another alternative / jump label.

For non-coherent arm{,64} we'd also need to use alternatives or jump
labels to for the cache maintainance ops, but that isn't a hard problem
either.


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ