lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 9 Feb 2021 18:43:13 +0800
From:   "wangyanan (Y)" <wangyanan55@...wei.com>
To:     Sean Christopherson <seanjc@...gle.com>
CC:     <kvm@...r.kernel.org>, <linux-kselftest@...r.kernel.org>,
        <linux-kernel@...r.kernel.org>,
        Paolo Bonzini <pbonzini@...hat.com>,
        Shuah Khan <shuah@...nel.org>,
        Andrew Jones <drjones@...hat.com>,
        Marc Zyngier <maz@...nel.org>, Ben Gardon <bgardon@...gle.com>,
        Peter Xu <peterx@...hat.com>,
        Aaron Lewis <aaronlewis@...gle.com>,
        Vitaly Kuznetsov <vkuznets@...hat.com>,
        <wanghaibin.wang@...wei.com>, <yuzenghui@...wei.com>
Subject: Re: [RFC PATCH 1/2] KVM: selftests: Add a macro to get string of
 vm_mem_backing_src_type

Hi Sean,

On 2021/2/9 1:43, Sean Christopherson wrote:
> On Mon, Feb 08, 2021, Yanan Wang wrote:
>> Add a macro to get string of the backing source memory type, so that
>> application can add choices for source types in the help() function,
>> and users can specify which type to use for testing.
>>
>> Signed-off-by: Yanan Wang <wangyanan55@...wei.com>
>> ---
>>   tools/testing/selftests/kvm/include/kvm_util.h | 3 +++
>>   tools/testing/selftests/kvm/lib/kvm_util.c     | 8 ++++++++
>>   2 files changed, 11 insertions(+)
>>
>> diff --git a/tools/testing/selftests/kvm/include/kvm_util.h b/tools/testing/selftests/kvm/include/kvm_util.h
>> index 5cbb861525ed..f5fc29dc9ee6 100644
>> --- a/tools/testing/selftests/kvm/include/kvm_util.h
>> +++ b/tools/testing/selftests/kvm/include/kvm_util.h
>> @@ -69,7 +69,9 @@ enum vm_guest_mode {
>>   #define PTES_PER_MIN_PAGE	ptes_per_page(MIN_PAGE_SIZE)
>>   
>>   #define vm_guest_mode_string(m) vm_guest_mode_string[m]
>> +#define vm_mem_backing_src_type_string(s) vm_mem_backing_src_type_string[s]
> Oof, I see this is just following vm_guest_mode_string.  IMO, defining the
> string to look like a function is unnecessary and rather mean.
>
>>   extern const char * const vm_guest_mode_string[];
>> +extern const char * const vm_mem_backing_src_type_string[];
>>   
>>   struct vm_guest_mode_params {
>>   	unsigned int pa_bits;
>> @@ -83,6 +85,7 @@ enum vm_mem_backing_src_type {
>>   	VM_MEM_SRC_ANONYMOUS,
>>   	VM_MEM_SRC_ANONYMOUS_THP,
>>   	VM_MEM_SRC_ANONYMOUS_HUGETLB,
>> +	NUM_VM_BACKING_SRC_TYPES,
>>   };
>>   
>>   int kvm_check_cap(long cap);
>> diff --git a/tools/testing/selftests/kvm/lib/kvm_util.c b/tools/testing/selftests/kvm/lib/kvm_util.c
>> index fa5a90e6c6f0..a9b651c7f866 100644
>> --- a/tools/testing/selftests/kvm/lib/kvm_util.c
>> +++ b/tools/testing/selftests/kvm/lib/kvm_util.c
>> @@ -165,6 +165,14 @@ const struct vm_guest_mode_params vm_guest_mode_params[] = {
>>   _Static_assert(sizeof(vm_guest_mode_params)/sizeof(struct vm_guest_mode_params) == NUM_VM_MODES,
>>   	       "Missing new mode params?");
>>   
>> +const char * const vm_mem_backing_src_type_string[] = {
> A shorter name would be nice, though I don't have a good suggestion.
>
>> +	"VM_MEM_SRC_ANONYMOUS        ",
>> +	"VM_MEM_SRC_ANONYMOUS_THP    ",
>> +	"VM_MEM_SRC_ANONYMOUS_HUGETLB",
> It'd be more robust to explicitly assign indices, that way tweaks to
> vm_mem_backing_src_type won't cause silent breakage.  Ditto for the existing
> vm_guest_mode_string.
>
> E.g. I think something like this would work (completely untested)
>
> const char *vm_guest_mode_string(int i)
> {
> 	static const char *const strings[] = {
> 		[VM_MODE_P52V48_4K]	= "PA-bits:52,  VA-bits:48,  4K pages",
> 		[VM_MODE_P52V48_64K]	= "PA-bits:52,  VA-bits:48, 64K pages",
> 		[VM_MODE_P48V48_4K]	= "PA-bits:48,  VA-bits:48,  4K pages",
> 		[VM_MODE_P48V48_64K]	= "PA-bits:48,  VA-bits:48, 64K pages",
> 		[VM_MODE_P40V48_4K]	= "PA-bits:40,  VA-bits:48,  4K pages",
> 		[VM_MODE_P40V48_64K]	= "PA-bits:40,  VA-bits:48, 64K pages",
> 		[VM_MODE_PXXV48_4K]	= "PA-bits:ANY, VA-bits:48,  4K pages",
> 	};
>
> 	_Static_assert(sizeof(strings)/sizeof(char *) == NUM_VM_MODES,
> 		       "Missing new mode strings?");
>
> 	TEST_ASSERT(i < NUM_VM_MODES);
>
> 	return strings[i];
> }

I think this is better. Moving these three staffs together into a single 
function and check the indices here is more reasonable.

Thanks,

Yanan.

>
>> +};
>> +_Static_assert(sizeof(vm_mem_backing_src_type_string)/sizeof(char *) == NUM_VM_BACKING_SRC_TYPES,
>> +	       "Missing new source type strings?");
>> +
>>   /*
>>    * VM Create
>>    *
>> -- 
>> 2.23.0
>>
> .

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ