[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b0a01a37aedde4b2da2edd7032dd7627@codeaurora.org>
Date: Wed, 17 Feb 2021 18:50:20 +0530
From: schowdhu@...eaurora.org
To: Vinod Koul <vkoul@...nel.org>
Cc: Andy Gross <agross@...nel.org>,
Bjorn Andersson <bjorn.andersson@...aro.org>,
Rob Herring <robh+dt@...nel.org>,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
linux-arm-msm@...r.kernel.org, devicetree@...r.kernel.org,
Rajendra Nayak <rnayak@...eaurora.org>,
Sibi Sankar <sibis@...eaurora.org>,
Sai Prakash Ranjan <saiprakash.ranjan@...eaurora.org>
Subject: Re: [PATCH V0 1/6] dt-bindings: Added the yaml bindings for DCC
On 2021-02-17 16:32, Vinod Koul wrote:
> On 17-02-21, 12:18, Souradeep Chowdhury wrote:
>> Documentation for Data Capture and Compare(DCC) device tree bindings
>> in yaml format.
>>
>> Signed-off-by: Souradeep Chowdhury <schowdhu@...eaurora.org>
>> ---
>> .../devicetree/bindings/arm/msm/qcom,dcc.yaml | 49
>> ++++++++++++++++++++++
>> 1 file changed, 49 insertions(+)
>> create mode 100644
>> Documentation/devicetree/bindings/arm/msm/qcom,dcc.yaml
>>
>> diff --git a/Documentation/devicetree/bindings/arm/msm/qcom,dcc.yaml
>> b/Documentation/devicetree/bindings/arm/msm/qcom,dcc.yaml
>> new file mode 100644
>> index 0000000..8f09578
>> --- /dev/null
>> +++ b/Documentation/devicetree/bindings/arm/msm/qcom,dcc.yaml
>> @@ -0,0 +1,49 @@
>> +# SPDX-License-Identifier: (GPL-2.0-or-later OR BSD-2-Clause)
>> +%YAML 1.2
>> +---
>> +$id: http://devicetree.org/schemas/arm/msm/qcom,dcc.yaml#
>> +$schema: http://devicetree.org/meta-schemas/core.yaml#
>> +
>> +title: Data Capture and Compare
>> +
>> +maintainers:
>> + - Souradeep Chowdhury <schowdhu@...eaurora.org>
>> +
>> +description: |
>> + DCC (Data Capture and Compare) is a DMA engine which is used to
>> save
>> + configuration data or system memory contents during catastrophic
>> failure
>> + or SW trigger.DCC is used to capture and store data for debugging
>> purpose
>
> space after .
Ack
>
>> +
>> +
>> +properties:
>> + compatible:
>> + items:
>> + - enum:
>> + - qcom,sm8150-dcc
>> + - const: qcom,dcc
>> +
>> + reg:
>> + items:
>> + - description: DCC base register region
>> + - description: DCC RAM base register region
>> +
>> + reg-names:
>> + items:
>> + - const: dcc-base
>> + - const: dcc-ram-base
>
> drop dcc from names
Since DCC has a dedicated SRAM, this has been named like this as
only base and ram-base are generic names. Let me know if this is
still required to be changed.
>
>> +
>> +required:
>> + - compatible
>> + - reg
>> + - reg-names
>> +
>> +additionalProperties: false
>> +
>> +examples:
>> + - |
>> + dcc@...a2000{
>> + compatible = "qcom,sm8150-dcc";
>
> should this not be:
> compatible = "qcom,sm8150-dcc", "qcom,dcc";
Ack
>
>> + reg = <0 0x010a2000 0 0x1000>,
>> + <0 0x010ae000 0 0x2000>;
>> + reg-names = "dcc-base", "dcc-ram-base";
>> + };
>> --
>> QUALCOMM INDIA, on behalf of Qualcomm Innovation Center, Inc. is a
>> member
>> of Code Aurora Forum, hosted by The Linux Foundation
Powered by blists - more mailing lists