lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Thu, 18 Feb 2021 01:28:03 +0000
From:   Chaitanya Kulkarni <Chaitanya.Kulkarni@....com>
To:     Pavel Machek <pavel@....cz>
CC:     "linux-xfs@...r.kernel.org" <linux-xfs@...r.kernel.org>,
        "linux-fsdevel@...r.kernel.org" <linux-fsdevel@...r.kernel.org>,
        "dm-devel@...hat.com" <dm-devel@...hat.com>,
        "linux-block@...r.kernel.org" <linux-block@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        "drbd-dev@...ts.linbit.com" <drbd-dev@...ts.linbit.com>,
        "xen-devel@...ts.xenproject.org" <xen-devel@...ts.xenproject.org>,
        "linux-nvme@...ts.infradead.org" <linux-nvme@...ts.infradead.org>,
        "linux-scsi@...r.kernel.org" <linux-scsi@...r.kernel.org>,
        "target-devel@...r.kernel.org" <target-devel@...r.kernel.org>,
        "linux-fscrypt@...r.kernel.org" <linux-fscrypt@...r.kernel.org>,
        "jfs-discussion@...ts.sourceforge.net" 
        <jfs-discussion@...ts.sourceforge.net>,
        "linux-nilfs@...r.kernel.org" <linux-nilfs@...r.kernel.org>,
        "ocfs2-devel@....oracle.com" <ocfs2-devel@....oracle.com>,
        "linux-pm@...r.kernel.org" <linux-pm@...r.kernel.org>,
        "linux-mm@...ck.org" <linux-mm@...ck.org>,
        "axboe@...nel.dk" <axboe@...nel.dk>,
        "philipp.reisner@...bit.com" <philipp.reisner@...bit.com>,
        "lars.ellenberg@...bit.com" <lars.ellenberg@...bit.com>,
        "konrad.wilk@...cle.com" <konrad.wilk@...cle.com>,
        "roger.pau@...rix.com" <roger.pau@...rix.com>,
        "minchan@...nel.org" <minchan@...nel.org>,
        "ngupta@...are.org" <ngupta@...are.org>,
        "sergey.senozhatsky.work@...il.com" 
        <sergey.senozhatsky.work@...il.com>,
        "agk@...hat.com" <agk@...hat.com>,
        "snitzer@...hat.com" <snitzer@...hat.com>,
        "hch@....de" <hch@....de>, "sagi@...mberg.me" <sagi@...mberg.me>,
        "martin.petersen@...cle.com" <martin.petersen@...cle.com>,
        "viro@...iv.linux.org.uk" <viro@...iv.linux.org.uk>,
        "tytso@....edu" <tytso@....edu>,
        "jaegeuk@...nel.org" <jaegeuk@...nel.org>,
        "ebiggers@...nel.org" <ebiggers@...nel.org>,
        "djwong@...nel.org" <djwong@...nel.org>,
        "shaggy@...nel.org" <shaggy@...nel.org>,
        "konishi.ryusuke@...il.com" <konishi.ryusuke@...il.com>,
        "mark@...heh.com" <mark@...heh.com>,
        "jlbec@...lplan.org" <jlbec@...lplan.org>,
        "joseph.qi@...ux.alibaba.com" <joseph.qi@...ux.alibaba.com>,
        Damien Le Moal <Damien.LeMoal@....com>,
        Naohiro Aota <Naohiro.Aota@....com>,
        "jth@...nel.org" <jth@...nel.org>,
        "rjw@...ysocki.net" <rjw@...ysocki.net>,
        "len.brown@...el.com" <len.brown@...el.com>,
        "akpm@...ux-foundation.org" <akpm@...ux-foundation.org>,
        "hare@...e.de" <hare@...e.de>,
        "gustavoars@...nel.org" <gustavoars@...nel.org>,
        "tiwai@...e.de" <tiwai@...e.de>,
        "alex.shi@...ux.alibaba.com" <alex.shi@...ux.alibaba.com>,
        "asml.silence@...il.com" <asml.silence@...il.com>,
        "ming.lei@...hat.com" <ming.lei@...hat.com>,
        "tj@...nel.org" <tj@...nel.org>, "osandov@...com" <osandov@...com>,
        "bvanassche@....org" <bvanassche@....org>,
        "jefflexu@...ux.alibaba.com" <jefflexu@...ux.alibaba.com>
Subject: Re: [RFC PATCH 29/34] power/swap: use bio_new in hib_submit_io

On 2/17/21 14:03, Pavel Machek wrote:
> Hi!
>> diff --git a/kernel/power/swap.c b/kernel/power/swap.c
>> index c73f2e295167..e92e36c053a6 100644
>> --- a/kernel/power/swap.c
>> +++ b/kernel/power/swap.c
>> @@ -271,13 +271,12 @@ static int hib_submit_io(int op, int op_flags, pgoff_t page_off, void *addr,
>>  		struct hib_bio_batch *hb)
>>  {
>>  	struct page *page = virt_to_page(addr);
>> +	sector_t sect = page_off * (PAGE_SIZE >> 9);
>>  	struct bio *bio;
>>  	int error = 0;
>>  
>> -	bio = bio_alloc(GFP_NOIO | __GFP_HIGH, 1);
>> -	bio->bi_iter.bi_sector = page_off * (PAGE_SIZE >> 9);
>> -	bio_set_dev(bio, hib_resume_bdev);
>> -	bio_set_op_attrs(bio, op, op_flags);
>> +	bio = bio_new(hib_resume_bdev, sect, op, op_flags, 1,
>> +		      GFP_NOIO | __GFP_HIGH);
>>  
> C function with 6 arguments... dunno. Old version looks comparable or
> even more readable...
>
> Best regards,
> 							Pavel
The library functions that are in the kernel tree which are used
in different file-systems and fabrics drivers do take 6 arguments.

Plus what is the point of duplicating code for mandatory
parameters all over the kernel ?

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ