lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 27 Feb 2021 13:52:09 -0700
From:   Mathieu Poirier <mathieu.poirier@...aro.org>
To:     Mike Leach <mike.leach@...aro.org>
Cc:     linux-arm-kernel <linux-arm-kernel@...ts.infradead.org>,
        Coresight ML <coresight@...ts.linaro.org>,
        "open list:DOCUMENTATION" <linux-doc@...r.kernel.org>,
        "Suzuki K. Poulose" <suzuki.poulose@....com>,
        Yabin Cui <yabinc@...gle.com>,
        Jonathan Corbet <corbet@....net>, Leo Yan <leo.yan@...aro.org>,
        Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
        Tingwei Zhang <tingwei@...eaurora.org>,
        Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v4 02/10] coresight: syscfg: Add registration and feature
 loading for cs devices

On Fri, Feb 26, 2021 at 07:14:32PM +0000, Mike Leach wrote:
> Hi Mathieu,
> 
> On Fri, 19 Feb 2021 at 18:43, Mathieu Poirier
> <mathieu.poirier@...aro.org> wrote:
> >
> > [...]
> >
> > > +/**
> > > + * List entry for Coresight devices that are registered as supporting complex
> > > + * config operations.
> > > + *
> > > + * @csdev:   The registered device.
> > > + * @match_info: The matching type information.
> > > + * @ops:     Operations supported by the registered device.
> > > + * @item:    list entry.
> > > + */
> > > +struct cscfg_csdev_register {
> > > +     struct coresight_device *csdev;
> > > +     struct cscfg_match_desc match_info;
> > > +     struct cscfg_csdev_feat_ops ops;
> > > +     struct list_head item;
> > > +};
> >
> > I would call this structure cscfg_registered_csdev and move it to
> > coresight-config.h.  That way it is consistent with cscfg_config_csdev and
> > cscfg_feature_csdev and located all in the same file.
> >
> 
> I was trying to separate structures that are used to define
> configurations and features, with those that are used to manage the
> same. Hence, most things in coresight_config.h define configurations,
> or their device loaded instance equivalents, and things in
> coresight_syscfg.h are management items. I am happy to change the name
> but would prefer is stay in coresight_syscfg.h

Ok

> 
> Thanks
> 
> Mike
> 

Powered by blists - more mailing lists