lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sat, 27 Feb 2021 16:16:14 +0900
From:   Masahiro Yamada <>
To:     Linus Torvalds <>
Cc:     Ard Biesheuvel <>,
        Russell King - ARM Linux admin <>,
        Florian Weimer <>,
        Arnd Bergmann <>,
        "Cc: Android Kernel" <>,
        "Theodore Ts'o" <>,
        Peter Zijlstra <>,
        Catalin Marinas <>,
        Nick Desaulniers <>,
        Linux Kernel Mailing List <>,
        Will Deacon <>,
        linux-arm-kernel <>
Subject: Re: [PATCH] compiler.h: Raise minimum version of GCC to 5.1 for arm64

Hi Linus,

On Fri, Jan 15, 2021 at 3:43 AM Linus Torvalds
<> wrote:
> On Thu, Jan 14, 2021 at 12:18 AM Ard Biesheuvel <> wrote:
> >
> > So if the arguments are piling up, what is holding us back, other than
> > inertia?
> I think we can most certainly just try increasing the minimum version
> to 5.1 in the next merge window and see.

Just a friendly reminder.

It will be nice to increase the minimum GCC version
to GCC 5.x globally.

Now, the version check has been moved to
scripts/, which is invoked from

If you decide to do this, please update
'gcc_min_version' in that file.

I'd like to suggest GCC 5.2 instead of 5.1
so that we can drop the following line
from arch/powerpc/Kconfig.

if GCC_VERSION >= 50200   # plugin support on gcc <= 5.1 is buggy on PPC

> > Note that banning 4.9 for arm64 and banning it in general should be
> > two different changes in any case, as the former will need to be
> > backported to -stable kernels as well.
> Yes. The arm64 issue is a clear and known bug, plus I suspect gcc-4.9
> is ridiculously old in the arm64 ecosystem anyway.
> So the arm64 issue is a bug-fix, the follow-up of just upgrading gcc
> requirements in general would be a "keep up with the times, and allow
> those variable declarations in loops".
>             Linus

Best Regards
Masahiro Yamada

Powered by blists - more mailing lists