lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 02 Mar 2021 07:48:25 +0100
From:   Takashi Iwai <tiwai@...e.de>
To:     Anton Yakovlev <anton.yakovlev@...nsynergy.com>
Cc:     <virtualization@...ts.linux-foundation.org>,
        <alsa-devel@...a-project.org>, <virtio-dev@...ts.oasis-open.org>,
        "Michael S. Tsirkin" <mst@...hat.com>,
        Jaroslav Kysela <perex@...ex.cz>,
        Takashi Iwai <tiwai@...e.com>, <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v6 9/9] ALSA: virtio: introduce device suspend/resume support

On Tue, 02 Mar 2021 07:29:20 +0100,
Anton Yakovlev wrote:
> 
> On 28.02.2021 13:05, Takashi Iwai wrote:
> > On Sat, 27 Feb 2021 09:59:56 +0100,
> > Anton Yakovlev wrote:
> >>
> 
> [snip]
> 
> >> --- a/sound/virtio/virtio_pcm.c
> >> +++ b/sound/virtio/virtio_pcm.c
> >> @@ -109,6 +109,7 @@ static int virtsnd_pcm_build_hw(struct virtio_pcm_substream *vss,
> >>                SNDRV_PCM_INFO_BATCH |
> >>                SNDRV_PCM_INFO_BLOCK_TRANSFER |
> >>                SNDRV_PCM_INFO_INTERLEAVED |
> >> +             SNDRV_PCM_INFO_RESUME |
> >>                SNDRV_PCM_INFO_PAUSE;
> >
> > Actually you don't need to set SNDRV_PCM_INFO_RESUME.
> > This flag means that the driver supports the full resume procedure,
> > which isn't often the case; with this, the driver is supposed to
> > resume the stream exactly from the suspended position.
> >
> > Most drivers don't set this but implement only the suspend-stop
> > action.  Then the application (or the sound backend) will re-setup the
> > stream and restart accordingly.
> 
> I tried to resume driver without SNDRV_PCM_INFO_RESUME, and alsa-lib
> called only ops->prepare(). It makes sense for a typical hw, but we have
> "clean" unconfigured device on resume. And we must set hw parameters as
> a first step. It means, that code should be more or less the same. And
> maybe it's better to set SNDRV_PCM_INFO_RESUME, since it allows us to
> resume substream in any situation (regardless of application behavior).
> I can refactor code to only send requests from trigger(RESUME) path and
> not to call ops itself. It should make code more straitforward. What do
> you say?

How about calling hw_params(NULL) conditionally in the prepare?
Doing the full stack work in the trigger callback is bad from the API
design POV; in general the trigger callback is supposed to be as short
as possible.


Takashi

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ