lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 1 Mar 2021 20:09:09 +0100
From:   Borislav Petkov <bp@...e.de>
To:     "Chang S. Bae" <chang.seok.bae@...el.com>
Cc:     tglx@...utronix.de, mingo@...nel.org, luto@...nel.org,
        x86@...nel.org, len.brown@...el.com, dave.hansen@...el.com,
        hjl.tools@...il.com, Dave.Martin@....com, jannh@...gle.com,
        mpe@...erman.id.au, carlos@...hat.com, tony.luck@...el.com,
        ravi.v.shankar@...el.com, libc-alpha@...rceware.org,
        linux-arch@...r.kernel.org, linux-api@...r.kernel.org,
        linux-kernel@...r.kernel.org, linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH v6 1/6] uapi: Define the aux vector AT_MINSIGSTKSZ

On Sat, Feb 27, 2021 at 08:59:06AM -0800, Chang S. Bae wrote:
> Define the AT_MINSIGSTKSZ in generic Linux. It is already used as generic
> ABI in glibc's generic elf.h, and this define will prevent future namespace
> conflicts. In particular, x86 is also using this generic definition.
> 
> Signed-off-by: Chang S. Bae <chang.seok.bae@...el.com>
> Reviewed-by: Len Brown <len.brown@...el.com>
> Cc: Carlos O'Donell <carlos@...hat.com>
> Cc: Dave Martin <Dave.Martin@....com>
> Cc: libc-alpha@...rceware.org
> Cc: linux-arch@...r.kernel.org
> Cc: linux-api@...r.kernel.org
> Cc: linux-arm-kernel@...ts.infradead.org
> Cc: linux-kernel@...r.kernel.org
> ---
> Change from v5:
> * Reverted the arm64 change. (Dave Martin)
> * Massaged the changelog.
> 
> Change from v4:
> * Added as a new patch (Carlos O'Donell)
> ---
>  include/uapi/linux/auxvec.h | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/include/uapi/linux/auxvec.h b/include/uapi/linux/auxvec.h
> index abe5f2b6581b..15be98c75174 100644
> --- a/include/uapi/linux/auxvec.h
> +++ b/include/uapi/linux/auxvec.h
> @@ -33,5 +33,8 @@
>  
>  #define AT_EXECFN  31	/* filename of program */
>  
> +#ifndef AT_MINSIGSTKSZ
> +#define AT_MINSIGSTKSZ	51	/* stack needed for signal delivery  */

I know glibc's comment says a similar thing but the correct thing to say
here should be "minimal stack size for signal delivery" or so. Even the
variable name alludes to that too.

-- 
Regards/Gruss,
    Boris.

SUSE Software Solutions Germany GmbH, GF: Felix Imend├Ârffer, HRB 36809, AG N├╝rnberg

Powered by blists - more mailing lists