[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210315082710.l7esv3kwickj6yg3@ti.com>
Date: Mon, 15 Mar 2021 13:57:12 +0530
From: Pratyush Yadav <p.yadav@...com>
To: <Tudor.Ambarus@...rochip.com>
CC: <michael@...le.cc>, <vigneshr@...com>,
<linux-mtd@...ts.infradead.org>, <miquel.raynal@...tlin.com>,
<richard@....at>, <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v2 4/5] mtd: spi-nor: Move Software Write Protection
logic out of the core
On 15/03/21 06:09AM, Tudor.Ambarus@...rochip.com wrote:
> On 3/6/21 1:19 PM, Michael Walle wrote:
> > EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe
> >
> > Am 2021-03-06 10:50, schrieb Tudor Ambarus:
> >> It makes the core file a bit smaller and provides better separation
> >> between the Software Write Protection features and the core logic.
> >> All the next generic software write protection features (e.g.
> >> Individual
> >> Block Protection) will reside in swp.c.
> >>
> >> Signed-off-by: Tudor Ambarus <tudor.ambarus@...rochip.com>
> >> ---
> >
> > [..]
> >
> >> @@ -3554,6 +3152,9 @@ int spi_nor_scan(struct spi_nor *nor, const char
> >> *name,
> >> if (ret)
> >> return ret;
> >>
> >> + if (nor->params->locking_ops)
> >
> > Should this be in spi_nor_register_locking_ops(), too? I.e.
> >
> > void spi_nor_register_locking_ops() {
> > if (!nor->params->locking_ops)
> > return;
> > ..
> > }
>
> Yes, the checking should be done inside spi_nor_register_locking_ops,
> will move it.
>
> Btw, what do you find a better name, spi_nor_register_locking_ops or
> spi_nor_init_locking_ops? Applies to OTP as well.
On a quick glance, spi_nor_register_locking_ops() can be mistaken to
mean "Register locking ops". That is, ops to lock/unlock flash
registers. If you do want to keep using "register", IMO
spi_nor_locking_ops_register() would be better.
>
> Thanks,
> ta
>
> >
> > I don't have a strong opinion on that so far. I just noticed because
> > I put the check into spi_nor_otp_init() for my OTP series. They should
> > be the same though.
> >
> >> + spi_nor_register_locking_ops(nor);
> >
> > -michael
>
--
Regards,
Pratyush Yadav
Texas Instruments Inc.
Powered by blists - more mailing lists