[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <641f4d6d-97d2-63a8-c61b-a42f71dcba6c@huawei.com>
Date: Mon, 15 Mar 2021 10:04:23 +0800
From: Miaohe Lin <linmiaohe@...wei.com>
To: Matthew Wilcox <willy@...radead.org>
CC: <akpm@...ux-foundation.org>, <ziy@...dia.com>,
<william.kucharski@...cle.com>, <vbabka@...e.cz>,
<richard.weiyang@...ux.alibaba.com>, <peterx@...hat.com>,
<anshuman.khandual@....com>, <thomas_os@...pmail.org>,
<rcampbell@...dia.com>, <aneesh.kumar@...ux.ibm.com>,
<yang.shi@...ux.alibaba.com>, <linux-kernel@...r.kernel.org>,
<linux-mm@...ck.org>
Subject: Re: [PATCH 1/6] mm/huge_memory.c: rework the function
vma_adjust_trans_huge()
Hi:
On 2021/3/14 4:03, Matthew Wilcox wrote:
> On Sat, Mar 13, 2021 at 05:32:19AM -0500, Miaohe Lin wrote:
>> +static inline void try_to_split_huge_pmd_address(struct vm_area_struct *vma, unsigned long address)
>> +{
>> + if (address & ~HPAGE_PMD_MASK &&
>> + range_in_vma(vma, address & HPAGE_PMD_MASK,
>> + (address & HPAGE_PMD_MASK) + HPAGE_PMD_SIZE))
>> + split_huge_pmd_address(vma, address, false, NULL);
>> +}
>
> This isn't "try to split". This is "split if needed". I think the
> comments also need to be moved up here.
>
Make sense. Would do it in v2! Thanks!
> I'm not even sure this is really an improvement.
> .
>
At least we can eliminate a couple of duplicated lines and use helper range_in_vma() to improve
the readability slightly. Right? :)
Powered by blists - more mailing lists