[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YFI7r+YdgdALlewB@infradead.org>
Date: Wed, 17 Mar 2021 18:26:07 +0100
From: Christoph Hellwig <hch@...radead.org>
To: "Matthew Wilcox (Oracle)" <willy@...radead.org>
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org,
linux-fsdevel@...r.kernel.org
Subject: Re: [PATCH v4 10/25] mm/util: Add folio_mapping and
folio_file_mapping
> +struct address_space *page_mapping(struct page *);
> +struct address_space *folio_mapping(struct folio *);
> +struct address_space *__folio_file_mapping(struct folio *);
> +
> +static inline struct address_space *folio_file_mapping(struct folio *folio)
> +{
> + if (unlikely(FolioSwapCache(folio)))
> + return __folio_file_mapping(folio);
I think __folio_file_mapping is badly misnamed as it only deals with
swapcache folios. Maybe that should be reflected in the name?
Also for all these funtions documentation would be very helpful, even if
the existing struct page based helpers don't have that either.
Powered by blists - more mailing lists