[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <f76f770c-908e-4f4f-f060-15f4d30652d8@redhat.com>
Date: Mon, 22 Mar 2021 10:53:46 +0100
From: David Hildenbrand <david@...hat.com>
To: Thomas Huth <thuth@...hat.com>,
Claudio Imbrenda <imbrenda@...ux.ibm.com>,
linux-kernel@...r.kernel.org
Cc: borntraeger@...ibm.com, frankja@...ux.ibm.com, cohuck@...hat.com,
kvm@...r.kernel.org, linux-s390@...r.kernel.org,
stable@...r.kernel.org
Subject: Re: [PATCH v1 1/2] s390/kvm: split kvm_s390_real_to_abs
On 20.03.21 05:57, Thomas Huth wrote:
> On 19/03/2021 20.33, Claudio Imbrenda wrote:
>> A new function _kvm_s390_real_to_abs will apply prefixing to a real address
>> with a given prefix value.
>>
>> The old kvm_s390_real_to_abs becomes now a wrapper around the new function.
>>
>> This is needed to avoid code duplication in vSIE.
>>
>> Cc: stable@...r.kernel.org
>> Signed-off-by: Claudio Imbrenda <imbrenda@...ux.ibm.com>
>> ---
>> arch/s390/kvm/gaccess.h | 23 +++++++++++++++++------
>> 1 file changed, 17 insertions(+), 6 deletions(-)
>>
>> diff --git a/arch/s390/kvm/gaccess.h b/arch/s390/kvm/gaccess.h
>> index daba10f76936..7c72a5e3449f 100644
>> --- a/arch/s390/kvm/gaccess.h
>> +++ b/arch/s390/kvm/gaccess.h
>> @@ -18,17 +18,14 @@
>>
>> /**
>> * kvm_s390_real_to_abs - convert guest real address to guest absolute address
>> - * @vcpu - guest virtual cpu
>> + * @prefix - guest prefix
>> * @gra - guest real address
>> *
>> * Returns the guest absolute address that corresponds to the passed guest real
>> - * address @gra of a virtual guest cpu by applying its prefix.
>> + * address @gra of by applying the given prefix.
>> */
>> -static inline unsigned long kvm_s390_real_to_abs(struct kvm_vcpu *vcpu,
>> - unsigned long gra)
>> +static inline unsigned long _kvm_s390_real_to_abs(u32 prefix, unsigned long gra)
>
> <bikeshedding>
> Just a matter of taste, but maybe this could be named differently?
> kvm_s390_real2abs_prefix() ? kvm_s390_prefix_real_to_abs()?
> </bikeshedding>
+1, I also dislike these "_.*" style functions here.
Reviewed-by: David Hildenbrand <david@...hat.com>
>
> Anyway:
> Reviewed-by: Thomas Huth <thuth@...hat.com>
>
--
Thanks,
David / dhildenb
Powered by blists - more mailing lists