[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1885296.1616410586@warthog.procyon.org.uk>
Date: Mon, 22 Mar 2021 10:56:26 +0000
From: David Howells <dhowells@...hat.com>
To: Matthew Wilcox <willy@...radead.org>
Cc: dhowells@...hat.com, Trond Myklebust <trondmy@...merspace.com>,
Anna Schumaker <anna.schumaker@...app.com>,
Steve French <sfrench@...ba.org>,
Dominique Martinet <asmadeus@...ewreck.org>,
Linus Torvalds <torvalds@...ux-foundation.org>,
Christoph Hellwig <hch@....de>,
Alexander Viro <viro@...iv.linux.org.uk>, linux-mm@...ck.org,
linux-cachefs@...hat.com, linux-afs@...ts.infradead.org,
linux-nfs@...r.kernel.org, linux-cifs@...r.kernel.org,
ceph-devel@...r.kernel.org, v9fs-developer@...ts.sourceforge.net,
linux-fsdevel@...r.kernel.org, Jeff Layton <jlayton@...hat.com>,
David Wysochanski <dwysocha@...hat.com>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v4 02/28] mm: Add an unlock function for PG_private_2/PG_fscache
Matthew Wilcox <willy@...radead.org> wrote:
> That also brings up that there is no set_page_private_2(). I think
> that's OK -- you only set PageFsCache() immediately after reading the
> page from the server. But I feel this "unlock_page_private_2" is actually
> "clear_page_private_2" -- ie it's equivalent to writeback, not to lock.
How about I do the following:
(1) Add set_page_private_2() or mark_page_private_2() to set the PG_fscache_2
bit. It could take a ref on the page here.
(2) Rename unlock_page_private_2() to end_page_private_2(). It could drop
the ref on the page here, but that then means I can't use
pagevec_release().
(3) Add wait_on_page_private_2() an analogue of wait_on_page_writeback()
rather than wait_on_page_locked().
(4) Provide fscache synonyms of the above.
David
Powered by blists - more mailing lists