lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 2 Apr 2021 10:59:25 +0200
From:   Jonathan Neuschäfer <j.neuschaefer@....net>
To:     Giulio Benetti <giulio.benetti@...ettiengineering.com>
Cc:     Dmitry Torokhov <dmitry.torokhov@...il.com>,
        Rob Herring <robh+dt@...nel.org>,
        Henrik Rydberg <rydberg@...math.org>,
        linux-input@...r.kernel.org, devicetree@...r.kernel.org,
        linux-kernel@...r.kernel.org,
        Jonathan Neuschäfer <j.ne@...teo.net>
Subject: Re: [PATCH v2 3/3] Input: add driver for the Hycon HY46XX touchpanel
 series

Hi,

a few remarks below.

On Fri, Apr 02, 2021 at 01:03:58AM +0200, Giulio Benetti wrote:
> This patch adds support for Hycon HY46XX.
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@...ettiengineering.com>
> ---
> V1->V2:
> * removed proximity-sensor-switch property according to previous patch
> As suggested by Dmitry Torokhov
> * moved i2c communaction to regmap use
> * added macro to avoid magic number
> * removed cmd variable that could uninitiliazed since we're using regmap now
> * removed useless byte masking
> * removed useless struct hycon_hy46xx_i2c_chip_data
> * used IRQF_ONESHOT only for isr
> ---


> +config TOUCHSCREEN_HYCON_HY46XX
> +	tristate "Hycon hy46xx touchscreen support"
> +	depends on I2C
> +	help
> +	  Say Y here if you have a touchscreen using Hycon hy46xx,
> +	  or something similar enough.

The "something similar enough" part doesn't seem relevant, because the
driver only lists HY46xx chips (in the compatible strings), and no chips
that are similar enough to work with the driver, but have a different
part number.

> +static void hycon_hy46xx_get_defaults(struct device *dev, struct hycon_hy46xx_data *tsdata)
> +{
> +	bool val_bool;
> +	int error;
> +	u32 val;
> +
> +	error = device_property_read_u32(dev, "threshold", &val);

This seems to follow the old version of the binding, where
Hycon-specific properties didn't have the "hycon," prefix.
Please check that the driver still works with a devicetree that follows
the newest version of the binding.

> +MODULE_AUTHOR("Giulio Benetti <giulio.benetti@...ronovasrl.com>");

This is a different email address than you used in the DT binding. If
this is intentional, no problem (Just letting you know, in case it's
unintentional).


Thanks,
Jonathan Neuschäfer

Download attachment "signature.asc" of type "application/pgp-signature" (834 bytes)

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ