[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210406185110.d7mp7grsevndcrr2@ti.com>
Date: Wed, 7 Apr 2021 00:21:12 +0530
From: Pratyush Yadav <p.yadav@...com>
To: Laurent Pinchart <laurent.pinchart@...asonboard.com>
CC: Mauro Carvalho Chehab <mchehab@...nel.org>,
Rob Herring <robh+dt@...nel.org>,
Kishon Vijay Abraham I <kishon@...com>,
Vinod Koul <vkoul@...nel.org>,
Peter Ujfalusi <peter.ujfalusi@...il.com>,
Maxime Ripard <mripard@...nel.org>,
Benoit Parrot <bparrot@...com>,
Hans Verkuil <hverkuil-cisco@...all.nl>,
Alexandre Courbot <acourbot@...omium.org>,
Stanimir Varbanov <stanimir.varbanov@...aro.org>,
Helen Koike <helen.koike@...labora.com>,
Michael Tretter <m.tretter@...gutronix.de>,
Peter Chen <peter.chen@....com>,
Chunfeng Yun <chunfeng.yun@...iatek.com>,
<linux-media@...r.kernel.org>, <devicetree@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, <linux-phy@...ts.infradead.org>,
<dmaengine@...r.kernel.org>, Vignesh Raghavendra <vigneshr@...com>,
Tomi Valkeinen <tomi.valkeinen@...asonboard.com>
Subject: Re: [PATCH 14/16] dt-bindings: phy: Convert Cadence DPHY binding to
YAML
On 02/04/21 01:23PM, Laurent Pinchart wrote:
> Hi Pratyush,
>
> Thank you for the patch.
>
> On Tue, Mar 30, 2021 at 11:03:46PM +0530, Pratyush Yadav wrote:
> > Convert Cadence DPHY binding to YAML.
> >
> > Signed-off-by: Pratyush Yadav <p.yadav@...com>
> > ---
> > .../devicetree/bindings/phy/cdns,dphy.txt | 20 --------
> > .../devicetree/bindings/phy/cdns,dphy.yaml | 51 +++++++++++++++++++
> > 2 files changed, 51 insertions(+), 20 deletions(-)
> > delete mode 100644 Documentation/devicetree/bindings/phy/cdns,dphy.txt
> > create mode 100644 Documentation/devicetree/bindings/phy/cdns,dphy.yaml
> >
> > diff --git a/Documentation/devicetree/bindings/phy/cdns,dphy.txt b/Documentation/devicetree/bindings/phy/cdns,dphy.txt
> > deleted file mode 100644
> > index 1095bc4e72d9..000000000000
> > --- a/Documentation/devicetree/bindings/phy/cdns,dphy.txt
> > +++ /dev/null
> > @@ -1,20 +0,0 @@
> > -Cadence DPHY
> > -============
> > -
> > -Cadence DPHY block.
> > -
> > -Required properties:
> > -- compatible: should be set to "cdns,dphy".
> > -- reg: physical base address and length of the DPHY registers.
> > -- clocks: DPHY reference clocks.
> > -- clock-names: must contain "psm" and "pll_ref".
> > -- #phy-cells: must be set to 0.
> > -
> > -Example:
> > - dphy0: dphy@...e0000{
> > - compatible = "cdns,dphy";
> > - reg = <0x0 0xfd0e0000 0x0 0x1000>;
> > - clocks = <&psm_clk>, <&pll_ref_clk>;
> > - clock-names = "psm", "pll_ref";
> > - #phy-cells = <0>;
> > - };
> > diff --git a/Documentation/devicetree/bindings/phy/cdns,dphy.yaml b/Documentation/devicetree/bindings/phy/cdns,dphy.yaml
> > new file mode 100644
> > index 000000000000..d1bbf96a8250
> > --- /dev/null
> > +++ b/Documentation/devicetree/bindings/phy/cdns,dphy.yaml
> > @@ -0,0 +1,51 @@
> > +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause)
> > +%YAML 1.2
> > +---
> > +$id: http://devicetree.org/schemas/phy/cdns,dphy.yaml#
> > +$schema: http://devicetree.org/meta-schemas/core.yaml#
> > +
> > +title: Cadence DPHY Device Tree Bindings
> > +
> > +maintainers:
> > + - Pratyush Yadav <p.yadav@...com>
> > +
> > +properties:
> > + compatible:
> > + items:
> > + - const: cdns,dphy
> > +
> > + reg:
> > + maxItems: 1
> > + description: Physical base address and length of the DPHY registers.
>
> You can drop the description.
Ok.
>
> > +
> > + clocks:
> > + maxItems: 2
> > + description: DPHY reference clocks.
>
> It's best to describe individual items, which will then allow dropping
> the maxItems property:
>
> clocks:
> items:
> - description: Description of the psm clock
> - description: Description of the pll_ref clock
Ok. Though I'd mention that I am not 100% sure what the pll_ref clock is
supposed to be. The original binding doesn't have a description either.
>
> > +
> > + clock-names:
> > + items:
> > + - const: psm
> > + - const: pll_ref
> > +
> > + "#phy-cells":
> > + const: 0
> > +
> > +required:
> > + - compatible
> > + - reg
> > + - clocks
> > + - clock-names
> > + - "#phy-cells"
> > +
> > +additionalProperties: false
> > +
> > +examples:
> > + - |
> > +
> > + dphy0: dphy@...e0000{
>
> This is copied verbatim from the existing description, but while at it,
> I'd rename the node from dphy@... to phy@..., as DT node are supposed to
> be named according to the class of devices, not the specific device
> type.
Ok.
>
> With these small issues addressed,
>
> Reviewed-by: Laurent Pinchart <laurent.pinchart@...asonboard.com>
Thanks.
>
> > + compatible = "cdns,dphy";
> > + reg = <0xfd0e0000 0x1000>;
> > + clocks = <&psm_clk>, <&pll_ref_clk>;
> > + clock-names = "psm", "pll_ref";
> > + #phy-cells = <0>;
> > + };
>
> --
> Regards,
>
> Laurent Pinchart
--
Regards,
Pratyush Yadav
Texas Instruments Inc.
Powered by blists - more mailing lists