[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <e603e511-6d58-38ea-d936-ed2f4efafc41@redhat.com>
Date: Mon, 26 Apr 2021 14:51:48 -0400
From: Waiman Long <llong@...hat.com>
To: Peter Zijlstra <peterz@...radead.org>,
Ingo Molnar <mingo@...hat.com>, Will Deacon <will@...nel.org>,
Boqun Feng <boqun.feng@...il.com>
Cc: linux-kernel@...r.kernel.org, Borislav Petkov <bp@...e.de>,
Ali Saidi <alisaidi@...zon.com>,
Steve Capper <steve.capper@....com>
Subject: Re: [PATCH] locking/qrwlock: queued_write_lock_slowpath() cleanup
On 4/26/21 2:50 PM, Waiman Long wrote:
> Make the code more readable by replacing the atomic_cmpxchg_acquire()
> by an equivalent atomic_try_cmpxchg_acquire() and change atomic_add()
> to atomic_or().
>
> For architectures that use qrwlock, I do not find one that has an
> atomic_add() defined but not an atomic_or(). I guess it should be fine
> by changing atomic_add() to atomic_or().
>
> Note that the previous use of atomic_add() isn't wrong as only one
> writer that is the wait_lock owner can set the waiting flag and the
> flag will be cleared later on when acquiring the write lock.
>
> Suggested-by: Linus Torvalds <torvalds@...ux-foundation.org>
> Signed-off-by: Waiman Long <longman@...hat.com>
> ---
> kernel/locking/qrwlock.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/locking/qrwlock.c b/kernel/locking/qrwlock.c
> index b94f3831e963..ec36b73f4733 100644
> --- a/kernel/locking/qrwlock.c
> +++ b/kernel/locking/qrwlock.c
> @@ -66,12 +66,12 @@ void queued_write_lock_slowpath(struct qrwlock *lock)
> arch_spin_lock(&lock->wait_lock);
>
> /* Try to acquire the lock directly if no reader is present */
> - if (!atomic_read(&lock->cnts) &&
> - (atomic_cmpxchg_acquire(&lock->cnts, 0, _QW_LOCKED) == 0))
> + if (!(cnts = atomic_read(&lock->cnts)) &&
> + atomic_try_cmpxchg_acquire(&lock->cnts, &cnts, _QW_LOCKED))
> goto unlock;
>
> /* Set the waiting flag to notify readers that a writer is pending */
> - atomic_add(_QW_WAITING, &lock->cnts);
> + atomic_or(_QW_WAITING, &lock->cnts);
>
> /* When no more readers or writers, set the locked flag */
> do {
Sorry, I missed the "v2" in the title.
Cheers,
Longman
Powered by blists - more mailing lists