[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <YIq5uQoBLuYvoFTk@kroah.com>
Date: Thu, 29 Apr 2021 15:50:49 +0200
From: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
To: linux-kernel@...r.kernel.org
Cc: Aditya Pakki <pakki001@....edu>, Kalle Valo <kvalo@...eaurora.org>
Subject: Re: [PATCH 3/7] Revert "orinoco: avoid assertion in case of NULL
pointer"
On Thu, Apr 29, 2021 at 03:08:07PM +0200, Greg Kroah-Hartman wrote:
> This reverts commit c705f9fc6a1736dcf6ec01f8206707c108dca824.
>
> Commits from @umn.edu addresses have been found to be submitted in "bad
> faith" to try to test the kernel community's ability to review "known
> malicious" changes. The result of these submissions can be found in a
> paper submitted to the 42nd IEEE Symposium on Security and Privacy
> entitled, "Open Source Insecurity: Stealthily Introducing
> Vulnerabilities via Hypocrite Commits" written by Qiushi Wu (University
> of Minnesota) and Kangjie Lu (University of Minnesota) but later
> withdrawn.
>
> Because of this, all submissions from this group must be reverted from
> the kernel tree and will need to be re-reviewed again to determine if
> they actually are a valid fix. Until that work is complete, remove this
> change to ensure that no problems are being introduced into the
> codebase.
>
> Cc: Aditya Pakki <pakki001@....edu>
> Cc: Kalle Valo <kvalo@...eaurora.org>
> Signed-off-by: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
> ---
> drivers/net/wireless/intersil/orinoco/orinoco_usb.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/drivers/net/wireless/intersil/orinoco/orinoco_usb.c b/drivers/net/wireless/intersil/orinoco/orinoco_usb.c
> index dd31929261ab..60e626eb913d 100644
> --- a/drivers/net/wireless/intersil/orinoco/orinoco_usb.c
> +++ b/drivers/net/wireless/intersil/orinoco/orinoco_usb.c
> @@ -1392,8 +1392,7 @@ static int ezusb_init(struct hermes *hw)
> struct ezusb_priv *upriv = hw->priv;
> int retval;
>
> - if (!upriv)
> - return -EINVAL;
> + BUG_ON(!upriv);
>
> upriv->reply_count = 0;
> /* Write the MAGIC number on the simulated registers to keep
> --
> 2.31.1
>
The original commit here looks correct, I'll drop this revert.
thanks,
greg k-h
Powered by blists - more mailing lists