[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20210512064629.13899-3-mcgrof@kernel.org>
Date: Wed, 12 May 2021 06:46:23 +0000
From: Luis Chamberlain <mcgrof@...nel.org>
To: axboe@...nel.dk
Cc: bvanassche@....org, ming.lei@...hat.com, hch@...radead.org,
jack@...e.cz, osandov@...com, linux-block@...r.kernel.org,
linux-kernel@...r.kernel.org, Luis Chamberlain <mcgrof@...nel.org>
Subject: [PATCH v1 2/8] block: move disk announce work from register_disk() to a helper
This moves quite a bit of code which does one thing into a helper.
We currently do not check for errors but we may decide that might
be desirable later.
This also makes the code easier to read.
This change has no functional changes.
Signed-off-by: Luis Chamberlain <mcgrof@...nel.org>
---
block/genhd.c | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/block/genhd.c b/block/genhd.c
index 51dff87c4756..484cda981b4e 100644
--- a/block/genhd.c
+++ b/block/genhd.c
@@ -429,6 +429,15 @@ static void disk_scan_partitions(struct gendisk *disk)
blkdev_put(bdev, FMODE_READ);
}
+static void disk_announce(struct gendisk *disk)
+{
+ struct device *ddev = disk_to_dev(disk);
+
+ /* announce the disk and partitions after all partitions are created */
+ dev_set_uevent_suppress(ddev, 0);
+ disk_uevent(disk, KOBJ_ADD);
+}
+
static void register_disk(struct device *parent, struct gendisk *disk,
const struct attribute_group **groups)
{
@@ -472,10 +481,7 @@ static void register_disk(struct device *parent, struct gendisk *disk,
return;
disk_scan_partitions(disk);
-
- /* announce the disk and partitions after all partitions are created */
- dev_set_uevent_suppress(ddev, 0);
- disk_uevent(disk, KOBJ_ADD);
+ disk_announce(disk);
if (disk->queue->backing_dev_info->dev) {
err = sysfs_create_link(&ddev->kobj,
--
2.30.2
Powered by blists - more mailing lists