[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20210512141054.2180373-1-jwi@linux.ibm.com>
Date: Wed, 12 May 2021 16:10:54 +0200
From: Julian Wiedmann <jwi@...ux.ibm.com>
To: Greg Kroah-Hartman <gregkh@...uxfoundation.org>
Cc: "Rafael J. Wysocki" <rafael@...nel.org>,
linux-kernel <linux-kernel@...r.kernel.org>,
Julian Wiedmann <jwi@...ux.ibm.com>
Subject: [PATCH] driver core: replace open-coded device_lock_assert()
Using the right wrapper makes it easier to associate this assert
statement with the device_[un]lock() helpers.
Signed-off-by: Julian Wiedmann <jwi@...ux.ibm.com>
---
drivers/base/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/base/core.c b/drivers/base/core.c
index 4a8bf8cda52b..bfa3536d48df 100644
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -3437,7 +3437,7 @@ bool kill_device(struct device *dev)
* to run while we are tearing out the bus/class/sysfs from
* underneath the device.
*/
- lockdep_assert_held(&dev->mutex);
+ device_lock_assert(dev);
if (dev->p->dead)
return false;
--
2.25.1
Powered by blists - more mailing lists