[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <b2b1f4e6-bc37-160b-5931-f64730d5ef53@huawei.com>
Date: Wed, 12 May 2021 10:02:16 +0800
From: Miaohe Lin <linmiaohe@...wei.com>
To: Matthew Wilcox <willy@...radead.org>
CC: <akpm@...ux-foundation.org>, <ziy@...dia.com>,
<william.kucharski@...cle.com>, <yang.shi@...ux.alibaba.com>,
<aneesh.kumar@...ux.ibm.com>, <rcampbell@...dia.com>,
<songliubraving@...com>, <kirill.shutemov@...ux.intel.com>,
<riel@...riel.com>, <hannes@...xchg.org>, <minchan@...nel.org>,
<hughd@...gle.com>, <adobriyan@...il.com>,
<linux-kernel@...r.kernel.org>, <linux-mm@...ck.org>,
<linux-fsdevel@...r.kernel.org>
Subject: Re: [PATCH v3 2/5] mm/huge_memory.c: use page->deferred_list
On 2021/5/12 7:03, Matthew Wilcox wrote:
> On Tue, May 11, 2021 at 09:48:54PM +0800, Miaohe Lin wrote:
>> Now that we can represent the location of ->deferred_list instead of
>> ->mapping + ->index, make use of it to improve readability.
>>
>> Reviewed-by: Yang Shi <shy828301@...il.com>
>> Reviewed-by: David Hildenbrand <david@...hat.com>
>> Signed-off-by: Miaohe Lin <linmiaohe@...wei.com>
>> ---
>> mm/huge_memory.c | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/mm/huge_memory.c b/mm/huge_memory.c
>> index 63ed6b25deaa..76ca1eb2a223 100644
>> --- a/mm/huge_memory.c
>> +++ b/mm/huge_memory.c
>> @@ -2868,7 +2868,7 @@ static unsigned long deferred_split_scan(struct shrinker *shrink,
>> spin_lock_irqsave(&ds_queue->split_queue_lock, flags);
>> /* Take pin on all head pages to avoid freeing them under us */
>> list_for_each_safe(pos, next, &ds_queue->split_queue) {
>> - page = list_entry((void *)pos, struct page, mapping);
>> + page = list_entry((void *)pos, struct page, deferred_list);
>> page = compound_head(page);
>
> This is an equivalent transformation, but it doesn't really go far
> enough. I think you want something like this:
>
> struct page *page, *next;
>
> list_for_each_entry_safe(page, next, &ds_queue->split_queue,
> deferred_list) {
> struct page *head = page - 1;
> ... then use head throughout ...
> }
>
Many thanks for your time and reminder. list_for_each_entry_safe is equivalent
to list_for_each_safe + list_entry and there is many places using list_for_each_safe
+ list_entry, so I think it's ok to keep the code as it is.
Thanks again. :)
> .
>
Powered by blists - more mailing lists