[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210514135712.GD4715@lst.de>
Date: Fri, 14 May 2021 15:57:12 +0200
From: Christoph Hellwig <hch@....de>
To: Logan Gunthorpe <logang@...tatee.com>
Cc: linux-kernel@...r.kernel.org, linux-nvme@...ts.infradead.org,
linux-block@...r.kernel.org, linux-pci@...r.kernel.org,
linux-mm@...ck.org, iommu@...ts.linux-foundation.org,
Stephen Bates <sbates@...thlin.com>,
Christoph Hellwig <hch@....de>,
Dan Williams <dan.j.williams@...el.com>,
Jason Gunthorpe <jgg@...pe.ca>,
Christian König <christian.koenig@....com>,
John Hubbard <jhubbard@...dia.com>,
Don Dutile <ddutile@...hat.com>,
Matthew Wilcox <willy@...radead.org>,
Daniel Vetter <daniel.vetter@...ll.ch>,
Jakowski Andrzej <andrzej.jakowski@...el.com>,
Minturn Dave B <dave.b.minturn@...el.com>,
Jason Ekstrand <jason@...kstrand.net>,
Dave Hansen <dave.hansen@...ux.intel.com>,
Xiong Jianxin <jianxin.xiong@...el.com>,
Bjorn Helgaas <helgaas@...nel.org>,
Ira Weiny <ira.weiny@...el.com>,
Robin Murphy <robin.murphy@....com>
Subject: Re: [PATCH v2 15/22] dma-direct: Support PCI P2PDMA pages in
dma-direct map_sg
> + for_each_sg(sgl, sg, nents, i) {
> + if (sg_is_dma_pci_p2pdma(sg)) {
> + sg_dma_unmark_pci_p2pdma(sg);
> + } else {
Double space here. We also don't really need the curly braces to start
with.
> + struct pci_p2pdma_map_state p2pdma_state = {};
> + enum pci_p2pdma_map_type map;
> struct scatterlist *sg;
> + int i, ret;
>
> for_each_sg(sgl, sg, nents, i) {
> + if (is_pci_p2pdma_page(sg_page(sg))) {
> + map = pci_p2pdma_map_segment(&p2pdma_state, dev, sg);
> + switch (map) {
Why not just:
switch (pci_p2pdma_map_segment(&p2pdma_state, dev,
sg)) {
(even better with a shorter name for p2pdma_state so that it all fits on
a single line)?
> + case PCI_P2PDMA_MAP_BUS_ADDR:
> + continue;
> + case PCI_P2PDMA_MAP_THRU_HOST_BRIDGE:
> + /*
> + * Mapping through host bridge should be
> + * mapped normally, thus we do nothing
> + * and continue below.
> + */
I have a bit of a hard time parsing this comment.
> + if (sg->dma_address == DMA_MAPPING_ERROR) {
> + ret = -EINVAL;
> goto out_unmap;
> + }
> sg_dma_len(sg) = sg->length;
> }
>
> @@ -411,7 +443,7 @@ int dma_direct_map_sg(struct device *dev, struct scatterlist *sgl, int nents,
>
> out_unmap:
> dma_direct_unmap_sg(dev, sgl, i, dir, attrs | DMA_ATTR_SKIP_CPU_SYNC);
> - return -EINVAL;
> + return ret;
Maybe just initialize ret to -EINVAL at declaration time to simplify this
a bit?
Powered by blists - more mailing lists