lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 17 May 2021 11:17:43 -0600
From:   Yu Zhao <yuzhao@...gle.com>
To:     Dong Aisheng <aisheng.dong@....com>
Cc:     Linux-MM <linux-mm@...ck.org>,
        linux-kernel <linux-kernel@...r.kernel.org>, dongas86@...il.com,
        Andrew Morton <akpm@...ux-foundation.org>,
        Andrey Konovalov <andreyknvl@...il.com>,
        Catalin Marinas <catalin.marinas@....com>,
        Kees Cook <keescook@...omium.org>
Subject: Re: [PATCH 1/5] mm: correct SECTION_SHIFT name in code comments

On Mon, May 17, 2021 at 5:21 AM Dong Aisheng <aisheng.dong@....com> wrote:
>
> Actually SECTIONS_SHIFT is used in the kernel code, fixed the code
> comments. BTW, also moved the code comment to where it's defined.
>
> Also fixed a checkpatch complain derived from the original code:
> WARNING: please, no space before tabs
> + * SECTIONS_SHIFT    ^I^I#bits space required to store a section #$
>
> Cc: Andrew Morton <akpm@...ux-foundation.org>
> Cc: Yu Zhao <yuzhao@...gle.com>
> Cc: Andrey Konovalov <andreyknvl@...il.com>
> Cc: Catalin Marinas <catalin.marinas@....com>
> Cc: Kees Cook <keescook@...omium.org>
> Signed-off-by: Dong Aisheng <aisheng.dong@....com>
> ---
>  include/linux/mmzone.h            | 2 --
>  include/linux/page-flags-layout.h | 3 +++
>  2 files changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> index 9cdc88d09f2b..fc23e36cb165 100644
> --- a/include/linux/mmzone.h
> +++ b/include/linux/mmzone.h
> @@ -1198,8 +1198,6 @@ static inline struct zoneref *first_zones_zonelist(struct zonelist *zonelist,
>  #ifdef CONFIG_SPARSEMEM
>
>  /*
> - * SECTION_SHIFT               #bits space required to store a section #
> - *
>   * PA_SECTION_SHIFT            physical address to/from section number
>   * PFN_SECTION_SHIFT           pfn to/from section number
>   */
> diff --git a/include/linux/page-flags-layout.h b/include/linux/page-flags-layout.h
> index ef1e3e736e14..aff616855492 100644
> --- a/include/linux/page-flags-layout.h
> +++ b/include/linux/page-flags-layout.h
> @@ -26,6 +26,9 @@
>
>  #define ZONES_WIDTH            ZONES_SHIFT
>
> +/*
> + * SECTIONS_SHIFT              #bits space required to store a section #
> + */

IMO, we should either make the original comment helpful or just remove
it. Moving it here doesn't improve readability because it's stating
the obvious.

>  #ifdef CONFIG_SPARSEMEM
>  #include <asm/sparsemem.h>
>  #define SECTIONS_SHIFT (MAX_PHYSMEM_BITS - SECTION_SIZE_BITS)
> --
> 2.25.1
>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ